Thread Rating:
  • 9 Vote(s) - 1.89 Average
  • 1
  • 2
  • 3
  • 4
  • 5
1.9 dw8 lack of power
#1
Hi there new to the forum first post hope someone can help. I have a 2006 1.9d berlingo revs ok when stationary go to drive its slow but picks up at 2750 rpm changed the EGR valve still no good the clutch isn't good thaught some Debre had damaged the fly wheel sensor fitted new one still no good any ideas no light coming on no fault codes showing. also when van gets up to temperature after going down gears when go to take off you get a diesel knock switch van off and on and knock dissapears
[-] The following 1 user says Thank You to carwood for this post:
  • Ol'Jeffers
Reply
#2
Sounds to me as if the engine injection timing is out .

Camshaft belt slack or pulley loose, camshaft sensor faulty (if fitted).

Remove the cam cover and check the belt
Reply
#3
do you need pins on dw8 to check timing
Reply
#4
yes you need pins to set and check camshaft timing , or drill bits the right size .

I think its either 8mm or/and 6mm dia.

Has there been any work done to it before the problems started ?
Reply
#5
no. Theres a solinoid with two breather pipes conecting to the egr valve will change that after i check timing
Reply
#6
Hi there sorry it took so long timing ok the solinoid is working fine took the cat off van is running fine
[-] The following 1 user says Thank You to carwood for this post:
  • addo
Reply
#7
(27-10-2013, 09:08 PM)carwood Wrote:  Hi there new to the forum first post hope someone can help. I have a 2006 1.9d berlingo revs ok when stationary go to drive its slow but picks up at 2750 rpm changed the EGR valve still no good the clutch isn't good thaught some Debre had damaged the fly wheel sensor fitted new one still no good any ideas no light coming on no fault codes showing. also when van gets up to temperature after going down gears when go to take off you get a diesel knock switch van off and on and knock dissapears

Hi Carwood, I see your van is running fine now?

To improve its performance do the following...........

1. Change the fuel filter - very easy to do

2. Remove the plastic inlet manifold (4 bolts) and clean it out thoroughly as they accumulate oil due to the breather pipe connected between it and the rocker cover.

If you think its running well now try these tips- You might be surprised.
Reply
#8
Back again van running like s**t it seems to be over fueling lots if suit out the back of the exhaust when you go down the gears and go to take off again diesel knock switch off and on van goes ok anyone any ideas what it could be
Reply
#9
The advance solenoid on the fuel pump sticking ? ( this depends what engine you have) or wires to it having a bad connection
Reply
#10
Hi did you think of checking the 'butterfly' before the inlet manifold? There are 2 vacuum pipes connected to it, seen them giving bother before.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Speedo/milometer fault
Last Post: Gixxerguyk8
Today 12:28 AM
» Replies: 15
» Views: 1399
Which wheel nuts?
Last Post: Stu999
Yesterday 11:50 PM
» Replies: 0
» Views: 20
VAN SECURITY
Last Post: ricc
Yesterday 08:29 PM
» Replies: 5
» Views: 148
Clanking Brake Pedal Solved At Last!
Last Post: rickandbev16
Yesterday 06:53 PM
» Replies: 17
» Views: 3403
Head Light Bulbs
Last Post: dargoion
Yesterday 06:03 PM
» Replies: 31
» Views: 837
Good Evening to you all.
Last Post: Tomcat3
Yesterday 05:06 PM
» Replies: 6
» Views: 151
Are Mud Flaps the Answer ?
Last Post: polar
Yesterday 05:06 PM
» Replies: 3
» Views: 100
EGR solenoid
Last Post: silver-slug
Yesterday 02:46 PM
» Replies: 17
» Views: 1363
ABS Modul
Last Post: 3rensho
Yesterday 11:00 AM
» Replies: 1
» Views: 71
Slow starter (diesel)
Last Post: zedhead
Yesterday 10:09 AM
» Replies: 10
» Views: 240

[-]
Recent Visitors
Locations of visitors to this page