Thread Rating:
  • 4 Vote(s) - 2.25 Average
  • 1
  • 2
  • 3
  • 4
  • 5
2000 MULTISPACE NEEDING INSTRUMENT CLUSTER ( CLOCKS ) ?
#1
HI , I AM HAVING A FEW PROBLEMS WITH THE TEMP CLOCK AND SPEEDO , THEY ARE NOT WORKING AND BEHAVING FAULTY SO IN DESPERATE NEED FOR SOME ADVICE AND IF ANY BEING BROKEN WOULD BE GREAT Big Grin CHEERS Big Grin[/b][/font]
Reply
#2
Check your earth to your cluster first of all and also the fuses
[-] The following 1 user says Thank You to homeruk for this post:
  • andy-womble
Reply
#3
Thanks for reply m8

already checked both and no issues
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Slow starter (diesel)
Last Post: zedhead
Today 10:09 AM
» Replies: 10
» Views: 215
ABS Modul
Last Post: highlander
Today 09:17 AM
» Replies: 0
» Views: 22
Type B MFD & Trip Computer
Last Post: cancunia
Today 08:55 AM
» Replies: 2
» Views: 76
Aftermarket radio stalk CTSCT003.2 Problem v2
Last Post: brajomobil
Today 07:39 AM
» Replies: 3
» Views: 112
jumps out in third gear..
Last Post: polar
Today 05:22 AM
» Replies: 7
» Views: 115
Fuel Guage wrong
Last Post: polar
Today 05:21 AM
» Replies: 1
» Views: 45
Wont start after dashboard removel
Last Post: joelfrodin
Yesterday 05:53 PM
» Replies: 10
» Views: 398
cold start
Last Post: geoff
Yesterday 05:23 PM
» Replies: 2
» Views: 80
Hello !
Last Post: geoff
Yesterday 09:52 AM
» Replies: 2
» Views: 63
Strut replacement- Spring Compression
Last Post: ffrenchie
Yesterday 09:15 AM
» Replies: 11
» Views: 439

[-]
Recent Visitors
Locations of visitors to this page