Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Changed starter - now battery is not charging
#1
After having multiple incidents on my 1.4 petrol Berlingo Mk1 with the starter not working (nothing happening when turning the key) and the solution was (the quite common) hitting it with something, I decided to replace the starter.

The new starter works like a charm, but quite instantly after replacing it the battery warning light started to illuminate. When checking the battery, it reads just around 12V when the engine is running and it looks as if the alternator is broke, but at the same time it seems too much of a coincidence!

So are there any other possible reasons for this to occur? Any easy way of checking? I tried to measure the alternator, but it seems quite difficult to get a good reading from it.

I also realize that it could have been an issue with the alternator in the first place, but I find it strange that the light did not illuminate before I replaced the starter and that the "standard trick" with hitting the starter worked out well.

Any help much appreciated! Wink
Reply
#2
Before you start splashing the cash these coincidences are normally because you have knocked something fitting the new starter or forgot to reattach something.

So first things first check all wiring and check output on alternator.

You can buy alternator tester which makes things easier for a couple of quid.
Reply
#3
Some more investigation leads to believing that the alternator may not be the problem after all...

For some reason, there are several things not working as intended:

- heating for the seats
- heating rear window
- heater
- front lights when light switch is in top position

So could it be as easy as a fuse being blown? Can't find any which looks broken though... Or could it be the BSI going mad?
Reply
#4
Did you do A bsi reset when you disconnected/reconnected the battery?

If not you need to do one , Google is your friend here.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Clanking Brake Pedal Solved At Last!
Last Post: rickandbev16
Today 06:53 PM
» Replies: 17
» Views: 3351
Head Light Bulbs
Last Post: dargoion
Today 06:03 PM
» Replies: 31
» Views: 804
Good Evening to you all.
Last Post: Tomcat3
Today 05:06 PM
» Replies: 6
» Views: 130
Are Mud Flaps the Answer ?
Last Post: polar
Today 05:06 PM
» Replies: 3
» Views: 77
EGR solenoid
Last Post: silver-slug
Today 02:46 PM
» Replies: 17
» Views: 1354
ABS Modul
Last Post: 3rensho
Today 11:00 AM
» Replies: 1
» Views: 63
Slow starter (diesel)
Last Post: zedhead
Today 10:09 AM
» Replies: 10
» Views: 235
Type B MFD & Trip Computer
Last Post: cancunia
Today 08:55 AM
» Replies: 2
» Views: 88
Aftermarket radio stalk CTSCT003.2 Problem v2
Last Post: brajomobil
Today 07:39 AM
» Replies: 3
» Views: 127
jumps out in third gear..
Last Post: polar
Today 05:22 AM
» Replies: 7
» Views: 132

[-]
Recent Visitors
Locations of visitors to this page