Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Clutch cable woes
#1
Hi all

As the title suggests the auto adjust clutch cable is breaking my heart and Im hoping someone on here might be able to help.
To make a long story short: Release bearing ate the pressure plate so I replaced clutch, pressure plate and bearing with LUK kit. I also replaced guide sleeve with genuine one from Citroen and bought spurious clutch cable from motor factors and replaced it.
The problem is clutch works fine for approx 100miles then the bite in pedal goes to the floor and its difficult go get it in to gear. To remedy this I pushed back the clutch fork with a long bar until I hear the auto adjuster click. That fixed the problem for another 100 miles and it broke again. I assumed the cable was faulty so replaced with another one supplied from motor factors. The same thing keeps happening. 

I checked everything multiple times and all seems ok as its impossible to put clutch facing backwards and also the cable can only be routed the correct way or no way at all as far as I can see.

I talked to a few mechanics and also a Citroen mechanic and there opinion was faulty clutch cable so I got another one. Put it in last night and removed white collar from auto adjuster and not bite at all. Clearly im doing something wrong as I cant be that unlucky to get 3 faulty cables but I dont know what to do. 

Any help is greatly appreciated...
Reply
#2
Hiya, I have been in a similar position. I then noticed the clutch fork is wobbly without the cable fitted, the cause is the thrust bearing has broken / come off the fork. NIGHTMARE !!!!!
You are lucky you only bought a pattern part, I have bought two Citroen Clutch Cables at £95 each...
I hope the issue you have is sorted soon..
Reply
#3
Thanks I hope its sorted soon too as its been parked up for over a week now. Yeah the oem cables are literally twice the price here. I cant understand why they don't sell a manually adjustable one. Might have to make one from all the spare cables ive collected now.. Undecided
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Good Evening to you all.
Last Post: Tomcat3
Today 05:06 PM
» Replies: 6
» Views: 127
Are Mud Flaps the Answer ?
Last Post: polar
Today 05:06 PM
» Replies: 3
» Views: 67
EGR solenoid
Last Post: silver-slug
Today 02:46 PM
» Replies: 17
» Views: 1348
ABS Modul
Last Post: 3rensho
Today 11:00 AM
» Replies: 1
» Views: 59
Slow starter (diesel)
Last Post: zedhead
Today 10:09 AM
» Replies: 10
» Views: 234
Type B MFD & Trip Computer
Last Post: cancunia
Today 08:55 AM
» Replies: 2
» Views: 86
Aftermarket radio stalk CTSCT003.2 Problem v2
Last Post: brajomobil
Today 07:39 AM
» Replies: 3
» Views: 124
jumps out in third gear..
Last Post: polar
Today 05:22 AM
» Replies: 7
» Views: 131
Fuel Guage wrong
Last Post: polar
Today 05:21 AM
» Replies: 1
» Views: 61
Wont start after dashboard removel
Last Post: joelfrodin
Yesterday 05:53 PM
» Replies: 10
» Views: 408

[-]
Recent Visitors
Locations of visitors to this page