Thread Rating:
  • 8 Vote(s) - 3.25 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] Engine cuts of a few seconds now and then
#1
Hi there

Last 2 weeks seems like a engine trouble has appear.
When i drive on highways, especially over 80/kmph the engine cuts off for a second or two, lige all lamps on, engine totally dead and i loose powerstearing. This sounds for me serious problem. But it has only happened about 3 times.
And last for a second or two. Every time it happened, i wanna stop the car and call rescue service, but then it just starts up again and all goes fine.
And then i manage to get home without trouble.
All services are taken on the car, oil filters and stuff like that.
What can this be? Any suggestion?
What can i suggest for the service shop here?
My Car INFO:
CITROËN BERLINGO (MF) 1.4 i (MFKFX, MFKFW)
2005 Mod
Volum: 1360 KW: 55 HK: 75 Fuel: Gasoline
Reply
#2
First thing I'd try is to connect a code reader to it and see what, if any, error messages are being logged.  That might point you in the right direction.
Reply
#3
Try checking the wire's coming from the battery terminal's follow them as far as you can they can come lose or brake and lose contact for a second or two
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
Reply
#4
(10-10-2014, 09:01 PM)Jed Clampit Wrote:  Try checking the wire's coming from the battery terminal's follow them as far as you can they can come lose or brake and lose contact for a second or two.

Thanks for the tip!
My Car INFO:
CITROËN BERLINGO (MF) 1.4 i (MFKFX, MFKFW)
2005 Mod
Volum: 1360 KW: 55 HK: 75 Fuel: Gasoline
Reply
#5
(10-10-2014, 09:01 PM)Jed Clampit Wrote:  Try checking the wire's coming from the battery terminal's follow them as far as you can they can come lose or brake and lose contact for a second or two

Can someone point me into the right tool for this?
I dont have no ODB tool around.
Whats the best one for this that does not cost a fortune?
My Car INFO:
CITROËN BERLINGO (MF) 1.4 i (MFKFX, MFKFW)
2005 Mod
Volum: 1360 KW: 55 HK: 75 Fuel: Gasoline
Reply
#6
Could it be the crank sensor? Just saw some other posts. Is it easy to change on my car?
My Car INFO:
CITROËN BERLINGO (MF) 1.4 i (MFKFX, MFKFW)
2005 Mod
Volum: 1360 KW: 55 HK: 75 Fuel: Gasoline
Reply
#7
I've been experiencing the same thing for some time now with my 2003 2.0HDi. It doesn't happen very often and got me stuck only once when the engine wouldn't start. It took me almost an hour to get it running again. I think it helped when I unplugged and plugged back in wiring related to diesel pump in the engine compartment fuse box. I'm yet to get back to it and fix properly. I guess, I'm not forced yet, although I lost the engine for couple of seconds the other morning... It is on the list...

Loose or bad connection...
Reply
#8
after a diagnostic test my error was: P0463 -Fuel Level Sensor.
That tells me either fuel Pump, or i gotta change filter (gonna change filter today to see if that helps)
Also i got another error saying: : P1110 - Air Cond. Button -
_could_ be related, as the engine acts weird when starting AC

Diagnose was done easy with a ODB2 Bluetooth
My Car INFO:
CITROËN BERLINGO (MF) 1.4 i (MFKFX, MFKFW)
2005 Mod
Volum: 1360 KW: 55 HK: 75 Fuel: Gasoline
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
VAN SECURITY
Last Post: ricc
Today 08:29 PM
» Replies: 5
» Views: 141
Clanking Brake Pedal Solved At Last!
Last Post: rickandbev16
Today 06:53 PM
» Replies: 17
» Views: 3385
Head Light Bulbs
Last Post: dargoion
Today 06:03 PM
» Replies: 31
» Views: 820
Good Evening to you all.
Last Post: Tomcat3
Today 05:06 PM
» Replies: 6
» Views: 143
Are Mud Flaps the Answer ?
Last Post: polar
Today 05:06 PM
» Replies: 3
» Views: 85
EGR solenoid
Last Post: silver-slug
Today 02:46 PM
» Replies: 17
» Views: 1358
ABS Modul
Last Post: 3rensho
Today 11:00 AM
» Replies: 1
» Views: 67
Slow starter (diesel)
Last Post: zedhead
Today 10:09 AM
» Replies: 10
» Views: 236
Type B MFD & Trip Computer
Last Post: cancunia
Today 08:55 AM
» Replies: 2
» Views: 88
Aftermarket radio stalk CTSCT003.2 Problem v2
Last Post: brajomobil
Today 07:39 AM
» Replies: 3
» Views: 129

[-]
Recent Visitors
Locations of visitors to this page