Thread Rating:
  • 3 Vote(s) - 4.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fuel Gauge or BSI?
#1
I have an ultra reliable 1.9d Berlingo 1, my dad is so impressed he went and bought himself a 1.9d Berlingo II 2003 model. Unfortunately he swallowed the 'I've got a new fuel sender unit it just needs fitting' line and parted with his cash - leaving me to sort it out as I'm fed up with recovering him when he runs out of fuel. Whilst removing the tank I found that it had recently been in and out ( nice big retaining washers leaving a distinct mark when refitted) and the new sender in the nice Genuine part box was indeed the old unit. This prompted me to check the resistances on both units - almost identical on max / min. I refitted the newer one to the tank. Before bolting the tank up I checked the reading at the end of the short wire from sender - no readings. Whoever fitted the unit had poked the multiplug with a rather fat test probe and enlarged the terminals in the plug - careful fixing and I now have readings on end of lead where it joins loom on vehicle. Tank on jack put approx 5 gallons in no gauge movement. Pins in multiplug on wiring loom also stretched by the affore mentioned probe - more careful fixing and I have a reading on gauge (1/2 tank) hooray! Added another 4 gallons of juice - still half a tank Sad Refitted tank pipes etc. and tested with diagnostic tool. (Autel DS708) When fuel gauge activated it goes 1/4 wait 1/2 wait wait wait wait wait and down again (when temp gauge activated it goes 1/4 wait 1/2 wait 3/4 wait full wait down again)

By the way fuel gauge started dropping immediately fuel is used and ran out at 1/4 tank without fuel light coming on. With sender disconnect gauge sits at bottom with light on.

Does this sound like a BSI or an in dash failure?

I don't have Lexia to test BSi at present but may order it as most of the problems I see relating to CAN, VAN or BSI issues tend to be on Citroens and Peugeots.
Reply
#2
If your still having problems with it, P/Mail me your Vin No. and I'll dig out the correct diagrams. :thumbsup:
2006 2.0hdi 600 with bench seat.  Cool
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Speedo/milometer fault
Last Post: Gixxerguyk8
Today 12:28 AM
» Replies: 15
» Views: 1399
Which wheel nuts?
Last Post: Stu999
Yesterday 11:50 PM
» Replies: 0
» Views: 20
VAN SECURITY
Last Post: ricc
Yesterday 08:29 PM
» Replies: 5
» Views: 148
Clanking Brake Pedal Solved At Last!
Last Post: rickandbev16
Yesterday 06:53 PM
» Replies: 17
» Views: 3403
Head Light Bulbs
Last Post: dargoion
Yesterday 06:03 PM
» Replies: 31
» Views: 837
Good Evening to you all.
Last Post: Tomcat3
Yesterday 05:06 PM
» Replies: 6
» Views: 151
Are Mud Flaps the Answer ?
Last Post: polar
Yesterday 05:06 PM
» Replies: 3
» Views: 100
EGR solenoid
Last Post: silver-slug
Yesterday 02:46 PM
» Replies: 17
» Views: 1363
ABS Modul
Last Post: 3rensho
Yesterday 11:00 AM
» Replies: 1
» Views: 71
Slow starter (diesel)
Last Post: zedhead
Yesterday 10:09 AM
» Replies: 10
» Views: 240

[-]
Recent Visitors
Locations of visitors to this page