Thread Rating:
  • 7 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fuse Box Problems - BSIE
#1
Hi,

I seem to be having what looks lke a common problem. First the dash lights started playing up, and then the wipers, and now the car will not start.

After looking around on the net, it looks like it will be the fault of the fuse box under the steering wheel.

I've taken it out, and got the following numbers off of it;

BSIE01-00HC
S118085320E

Is there any issue with getting a different one, and then just replacing it - are there any programming issues I need to watch out for?

I managed to track a second hand one down, that has the following number:

S118085320A

The difference only being the last number - any idea if this will work?

Finally, if it does not, does anyone know where I could find a second hand unit?

Thanks alot
Chris

Reply
#2
Hi Chris and thanks for saying hello. Might help to know what type of Berli we're talking about here. Then the guru's can chime in.
2010 Berlingo Multispace HDi 110 with FAP. Persamos green.

[Image: ab197646.gif]
Reply
#3
It may be that all that's needed is for the BSI to be reset/or the firmware re-written.
Authorised Citroen repairers can do this and they're cheaper than main dealers.
Although you'll have to find a garage that have Citroen's Lexia
or the Peugeot equivalent it may still prove to be the cheap option.
I very much suspect that if you were to get a s/h BSI unit it would still need to be set up for your vehicle.
HTH:thumbsup:
The Older I get the Better I Was!  Cool
Reply
#4
Hi,

Thanks for the reponses so far.
it's a 2007 1,4 petrol van

cheers
chris
Reply
#5
Hi Chris.
Who is manufacturer of BSI? Siemens, Valeo?
Reply
#6
Siemens
Reply
#7
Have you tried the BSI reset procedure? It can be found here:

http://www.bba-reman.com/content.aspx?co...ol_failure

Worth a shot??
Adam..2003..1.9D..LX..Silver Crew Cab Van.....
If at first you don't succeed, destroy all evidence that you tried.
Reply
#8
Does any aftermarket alarm system installed in your car?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Slow starter (diesel)
Last Post: zedhead
Today 10:09 AM
» Replies: 10
» Views: 217
ABS Modul
Last Post: highlander
Today 09:17 AM
» Replies: 0
» Views: 22
Type B MFD & Trip Computer
Last Post: cancunia
Today 08:55 AM
» Replies: 2
» Views: 76
Aftermarket radio stalk CTSCT003.2 Problem v2
Last Post: brajomobil
Today 07:39 AM
» Replies: 3
» Views: 112
jumps out in third gear..
Last Post: polar
Today 05:22 AM
» Replies: 7
» Views: 115
Fuel Guage wrong
Last Post: polar
Today 05:21 AM
» Replies: 1
» Views: 45
Wont start after dashboard removel
Last Post: joelfrodin
Yesterday 05:53 PM
» Replies: 10
» Views: 398
cold start
Last Post: geoff
Yesterday 05:23 PM
» Replies: 2
» Views: 80
Hello !
Last Post: geoff
Yesterday 09:52 AM
» Replies: 2
» Views: 63
Strut replacement- Spring Compression
Last Post: ffrenchie
Yesterday 09:15 AM
» Replies: 11
» Views: 439

[-]
Recent Visitors
Locations of visitors to this page