Thread Rating:
  • 8 Vote(s) - 3.63 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Idle speed Issues??
#1
Idle speed issues. Has anyone experienced this? I have a 1.8 petrol berlingo and sometimes while driving the engine won't return to normal idle speed and sits at 2000rpm making smooth starts really tricky. it doesn't last and is a random problem. Its really annoying, I have replaced the airflow sensor but the problem remains. Any help would be appreciated.
thanks clare xBig Grin
Reply
#2
Are the revs unruly at idle Clare? As in are they all over the place, or just sit at 2k rpm?
Want Help with the Forum? Read Help Documents Here
 [Image: mybbsig.php]

Reply
#3
By the way, this isn't you is it? http://www.berlingoforum.co.uk/member.ph...e&uid=1628
Want Help with the Forum? Read Help Documents Here
 [Image: mybbsig.php]

Reply
#4
(22-11-2011, 10:59 PM)Andre Wrote:  By the way, this isn't you is it? http://www.berlingoforum.co.uk/member.ph...e&uid=1628

yes thats me i signed in on facebook and it aded me as new lol
(22-11-2011, 11:03 PM)clare baird Wrote:  
(22-11-2011, 10:59 PM)Andre Wrote:  By the way, this isn't you is it? http://www.berlingoforum.co.uk/member.ph...e&uid=1628

yes thats me i signed in on facebook and it aded me as new lol

the revs just sit a 2000rpm dont they they dont go up and down
Reply
#5
You're everywhere! Accounts merged to your original one.

Want Help with the Forum? Read Help Documents Here
 [Image: mybbsig.php]

[-] The following 1 user says Thank You to Andre for this post:
  • clare baird
Reply
#6
(22-11-2011, 11:07 PM)Andre Wrote:  You're everywhere! Accounts merged to your original one.

thanks so now when i log in from fb wil it take me to this one i take it?
and my problem have u ever had that?
and it cutsout at round abouts too intermitent can go for ages its fine then all sudden goes again any ideas?
Reply
#7
Hi Clare

Hmmmm. My 2004 model does the odd weird thing at idle from time to time, but I think mine gets a bit upset by the lpg.

Do you mean you've changed the map sensor?

Looks like this map

Have you had a look to see if there are any vacuum leaks, split hoses, that sort of thing? Hissings sounds when car is running....?
Reply
#8
(22-11-2011, 11:42 PM)tucker Wrote:  Hi Clare

Hmmmm. My 2004 model does the odd weird thing at idle from time to time, but I think mine gets a bit upset by the lpg.

Do you mean you've changed the map sensor?

Looks like this map

map sensor been changed twice my bf fixes cars hes bamboozled hes tried all that u said checking for those things
any other siggestions or is it soemthign il have to live with lol
Have you had a look to see if there are any vacuum leaks, split hoses, that sort of thing? Hissings sounds when car is running....?

Reply
#9
any more things i cna look out for for this fault anyone got any suggestions its really annoying
Reply
#10
Most cars like fords its the idle control valve, it's another thing to check.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Good Evening to you all.
Last Post: Tomcat3
Today 05:06 PM
» Replies: 6
» Views: 127
Are Mud Flaps the Answer ?
Last Post: polar
Today 05:06 PM
» Replies: 3
» Views: 67
EGR solenoid
Last Post: silver-slug
Today 02:46 PM
» Replies: 17
» Views: 1348
ABS Modul
Last Post: 3rensho
Today 11:00 AM
» Replies: 1
» Views: 59
Slow starter (diesel)
Last Post: zedhead
Today 10:09 AM
» Replies: 10
» Views: 234
Type B MFD & Trip Computer
Last Post: cancunia
Today 08:55 AM
» Replies: 2
» Views: 86
Aftermarket radio stalk CTSCT003.2 Problem v2
Last Post: brajomobil
Today 07:39 AM
» Replies: 3
» Views: 124
jumps out in third gear..
Last Post: polar
Today 05:22 AM
» Replies: 7
» Views: 131
Fuel Guage wrong
Last Post: polar
Today 05:21 AM
» Replies: 1
» Views: 61
Wont start after dashboard removel
Last Post: joelfrodin
Yesterday 05:53 PM
» Replies: 10
» Views: 408

[-]
Recent Visitors
Locations of visitors to this page