Thread Rating:
  • 3 Vote(s) - 2.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Non turning over 2.0 HDI
#1
Hopefully someone can help:-
A few days ago went to start my Berlingo and it turned over slowly and wouldn't start, so I used the wifes car to jump start. After connecting the jump leads the Berlingo wouldn't even turn over, so I have charged the battery and still nothing. All I get is a click from the relay on the fuse board. I have tried to reset the BSI but nothing has changed. Today I have put a new battery on and have noticed the dash says that it is in Eco mode and it still wont turn over.
Thanks in advance Mark
Reply
#2
Eco mode doesn't early mean anything bad, it will come out of it once a charging current is received by the battery, ie it starts.
Sounds like your starter motor has failed, one way to find out is to bump start the car, my bet is it will start ok with a push, and then not once switched off.
Reply
#3
(28-12-2013, 05:10 PM)Lighty Wrote:  Eco mode doesn't early mean anything bad, it will come out of it once a charging current is received by the battery, ie it starts.
Sounds like your starter motor has failed, one way to find out is to bump start the car, my bet is it will start ok with a push, and then not once switched off.

Thanks for that i will have to try that tomorrow
[-] The following 1 user says Thank You to Rabbit73 for this post:
  • RolyG
Reply
#4
Thanks Lighty,
Have managed to start the Berlingo this morning with a bump start Smile Have taken the starter motor off and given it a test and it is to fault, so it will be a trip to the motor factors tomorrow. Again many thanks Mark
[-] The following 1 user says Thank You to Rabbit73 for this post:
  • RolyG
Reply
#5
(29-12-2013, 12:45 PM)Rabbit73 Wrote:  Thanks Lighty,
Have managed to start the Berlingo this morning with a bump start Smile Have taken the starter motor off and given it a test and it is to fault, so it will be a trip to the motor factors tomorrow. Again many thanks Mark

New starter motor now fitted and all up and running, many thanks to Lighty
Reply
#6
Yep! That Lighty's a good man!Confusedalut:Confusedalut:
The Older I get the Better I Was!  Cool
[-] The following 1 user says Thank You to Ol'Jeffers for this post:
  • addo
Reply
#7
(02-01-2014, 04:41 PM)OlJeffers Wrote:  Yep! That Lighty's a good man!Confusedalut:Confusedalut:

Here here, def a good man Confusedalut:Confusedalut:
A good forum too, now sorted a few little probs out using this site Confusedalut:Confusedalut:
[-] The following 1 user says Thank You to Rabbit73 for this post:
  • addo
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Good Evening to you all.
Last Post: Tomcat3
Today 05:06 PM
» Replies: 6
» Views: 127
Are Mud Flaps the Answer ?
Last Post: polar
Today 05:06 PM
» Replies: 3
» Views: 67
EGR solenoid
Last Post: silver-slug
Today 02:46 PM
» Replies: 17
» Views: 1348
ABS Modul
Last Post: 3rensho
Today 11:00 AM
» Replies: 1
» Views: 59
Slow starter (diesel)
Last Post: zedhead
Today 10:09 AM
» Replies: 10
» Views: 234
Type B MFD & Trip Computer
Last Post: cancunia
Today 08:55 AM
» Replies: 2
» Views: 86
Aftermarket radio stalk CTSCT003.2 Problem v2
Last Post: brajomobil
Today 07:39 AM
» Replies: 3
» Views: 124
jumps out in third gear..
Last Post: polar
Today 05:22 AM
» Replies: 7
» Views: 131
Fuel Guage wrong
Last Post: polar
Today 05:21 AM
» Replies: 1
» Views: 61
Wont start after dashboard removel
Last Post: joelfrodin
Yesterday 05:53 PM
» Replies: 10
» Views: 408

[-]
Recent Visitors
Locations of visitors to this page