Thread Rating:
  • 4 Vote(s) - 2.25 Average
  • 1
  • 2
  • 3
  • 4
  • 5
berlingo diesel misfiring on partial throttle.
#1
ive got a misfire in my berlingo. Its fine when full throttle as on the motorwat 70mph, but when i back off due to traffic or a 50 mph zone and my throttle control is light, the van judders and misses. i have a faulty fuel sender and have run out of diesel twice recently. However, i have driven several hundred miles since this so an air lock is out of the equation. Any suggestions as to what it might be?

Thanks.
Reply
#2
I have exactly the same problem only mine now also happens 30 in 3rd 40 in 4th etc...

see -
http://www.berlingoforum.co.uk/showthread.php?tid=4525
Reply
#3
(22-01-2014, 03:21 PM)runningman Wrote:  I have exactly the same problem only mine now also happens 30 in 3rd 40 in 4th etc...

see -
http://www.berlingoforum.co.uk/showthread.php?tid=4525

Yes, mine is the same too. doesnt matter what gear it is in. its worse at around 1800-2000 RPM.
Reply
#4
I have same problem at 50 mph in 5th gear ! I have replaced egr valve , air mass metre , crank and camshaft sensors , temperature sender , throttle unit all with genuine parts and diesel and air filter and it still does it ! Not happy !
Reply
#5
(26-01-2014, 10:01 AM)royboy302 Wrote:  I have same problem at 50 mph in 5th gear ! I have replaced egr valve , air mass metre , crank and camshaft sensors , temperature sender , throttle unit all with genuine parts and diesel and air filter and it still does it ! Not happy !


hi new here

ive exactly the same problem

shuddering at low speeds eg 50 mph in 5th gear

so far heres all ive replaced

all the engine mounts " they where worn from the shuddering but they are not the cause "

airflow metre
driveshafts and bearings
the bottom engine mount was loose but again this was just caused by the shudder .
cheaked and cleaned the egr valve
cheaked tyres and wheel balance
cleaned the crankshart sensor
added diesel additives

none of these worked

its driving me nuts
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Good Evening to you all.
Last Post: Tomcat3
Today 05:06 PM
» Replies: 6
» Views: 127
Are Mud Flaps the Answer ?
Last Post: polar
Today 05:06 PM
» Replies: 3
» Views: 67
EGR solenoid
Last Post: silver-slug
Today 02:46 PM
» Replies: 17
» Views: 1348
ABS Modul
Last Post: 3rensho
Today 11:00 AM
» Replies: 1
» Views: 59
Slow starter (diesel)
Last Post: zedhead
Today 10:09 AM
» Replies: 10
» Views: 234
Type B MFD & Trip Computer
Last Post: cancunia
Today 08:55 AM
» Replies: 2
» Views: 86
Aftermarket radio stalk CTSCT003.2 Problem v2
Last Post: brajomobil
Today 07:39 AM
» Replies: 3
» Views: 124
jumps out in third gear..
Last Post: polar
Today 05:22 AM
» Replies: 7
» Views: 131
Fuel Guage wrong
Last Post: polar
Today 05:21 AM
» Replies: 1
» Views: 61
Wont start after dashboard removel
Last Post: joelfrodin
Yesterday 05:53 PM
» Replies: 10
» Views: 408

[-]
Recent Visitors
Locations of visitors to this page