Thread Rating:
  • 2 Vote(s) - 2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Power keeps cutting out
#1
Hi all, i bought a 2001 multispace forte last week and a couple of times when i have been driving along the power from the accelerator cuts out and the rev counter stops working, but the engine still ticks over. I have to switch the ignition off then on again and it works fine except the rev counter doesnt work for a while then after a bit that too starts working again, has anyone else had the same issue?
Reply
#2
Which engine do you have?

Is there any warning lights on the dash?
Reply
#3
Its the 1.6 petrol, yes the engine management light comes on.
Reply
#4
First thing first,

You need to get the codes read then come back here for advice
Reply
#5
I dont mean to sound dimb but what do you mean by codes?
Reply
#6
Edit wrong advice, my bad.
Reply
#7
You'll need to use the Lexia3 system to read out the codes on a Mk. I Berlingo.

A generic OBD II reader won't be able to talk to the ECU as the interface is slightly non-standard. (The connector is under the dash, by the fuse box somewhere. )
Reply
#8
When the eml comes on not only does it tell you there is a fault , it will store a code that relates to that fault.

Without knowing what that code is on a modern car you are working in the dark most of the time.

This will require a trip to the dealers or a friendly garage which has the Lexia 3 software
Reply
#9
There are a few people on here that have the un-official Lexia 3 or Diagbox software who might be in your area.
There was a thread on the general page last week listing who they were and where they are.
Have a look to see if there is anyone near you who can help as going to Citroën will cost you a bob or two.
I have the same sort of problem but I am waiting on the software to come in the post so that I can diagnose the fault.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
2012 enterprise berlingo ...
Last Post:Top drive
Today 06:57 AM
» Replies: 10
» Views: 251
Poor cold starting. Whats...
Last Post:Top drive
Today 06:24 AM
» Replies: 9
» Views: 124
lubricating door
Last Post:ron
Yesterday 10:21 PM
» Replies: 6
» Views: 147
Rear light Cluster
Last Post:Jed Clampit
Yesterday 09:52 PM
» Replies: 6
» Views: 135
2.0 HDi fuel issues as pe...
Last Post:G.mk3
Yesterday 08:52 PM
» Replies: 6
» Views: 142
1.6 16v petrol cambelt
Last Post:sks01773
Yesterday 07:27 PM
» Replies: 16
» Views: 381
Roof noise
Last Post:Opensauce
Yesterday 06:39 PM
» Replies: 5
» Views: 136
12v for lighter front
Last Post:Matija Danko
Yesterday 05:15 PM
» Replies: 19
» Views: 432
Fuel consumption
Last Post:ron
Yesterday 04:30 PM
» Replies: 7
» Views: 162
Lexia clone that works wi...
Last Post:kennard
Yesterday 04:22 PM
» Replies: 60
» Views: 1926

Locations of visitors to this page