Thread Rating:
  • 6 Vote(s) - 2.17 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Possible BSI Solution
#1
Evening guys. I've got a 2003 1.9d van (facelift model) that has no clocks / instruments working. It runs fine and lights work however indicating makes the glow plug light flash. I've popped a set of clocks in with no joy. After inspection it appears that the connector from instruments into BSI has suffered slight damp which is causing the problem. Now, before I get it sent away for reman I had a thought and wanted to see what you guys think...

I can remove the old BSI and pop in a used one. If I were to bypass the immobiliser would a used BSI work??? I've tried bypassing immobiliser and running van without BSI and it runs fine so is there anything else that would prevent a used BSI working.

Any / all thoughts welcome.

Phill.
Reply
#2
No you should be fine running the van, but the configuration may need changing to suit your van, get it on peugeot planet and print the list of options off, then reprogram the new bsi with it, it's easy to break bits, we had a guy who did this and just plugged the bsi in, it was fine until he locked the van, bsi had deadlocking, his locks weren't and it killed the door latches... Be warned to get someone who knows what there doing Wink
Reply
#3
Thanks. TBH I cracked my bsi open Friday night just for a nose and it looked fine inside so have sent it away to rollingmotion for inspection / repair. I don't need the van for a few weeks anyway so thought I'd try that route first.

On a related subject I felt the carpet in the drivers footwell and although it felt dry to the touch when I lifted the carpet it was saturated. I got the wet and dry vac in and have removed aprox 3/4 bucket of water from the backing foam and it's still damp. Have took it out to air. After checking windscreen etc it would appear the culprit was leave and crap blocked the drivers side drain hole beneath the wipers. Couple that with the fact the vans been sat facing steeply uphill for about a month and I think we know where the damp connected came from in the first place.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
DW8 engine tapping
Last Post:jj9
Today 01:14 AM
» Replies: 3
» Views: 91
Rear window heater repair
Last Post:Silverberlingo
Yesterday 11:38 PM
» Replies: 0
» Views: 25
New PureTech 110 S&S Flai...
Last Post:Jed Clampit
Yesterday 09:04 PM
» Replies: 3
» Views: 57
What website to pass time...
Last Post:Solent
Yesterday 08:32 PM
» Replies: 0
» Views: 32
Berlingo Parts
Last Post:Sb12
Yesterday 07:56 PM
» Replies: 0
» Views: 34
Rear hub nut torque setti...
Last Post:jj9
Yesterday 07:55 PM
» Replies: 15
» Views: 261
temperatue dial
Last Post:Kokain
Yesterday 05:28 PM
» Replies: 3
» Views: 76
Trip Computer on Type A M...
Last Post:cancunia
Yesterday 03:50 PM
» Replies: 0
» Views: 25
Loud beeping from radio u...
Last Post:nicko
Yesterday 03:49 PM
» Replies: 3
» Views: 116
Ligts won't go off!
Last Post:Berlingos12
Yesterday 02:50 PM
» Replies: 10
» Views: 470

Locations of visitors to this page