Thread Rating:
  • 6 Vote(s) - 2.17 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Possible BSI Solution
Evening guys. I've got a 2003 1.9d van (facelift model) that has no clocks / instruments working. It runs fine and lights work however indicating makes the glow plug light flash. I've popped a set of clocks in with no joy. After inspection it appears that the connector from instruments into BSI has suffered slight damp which is causing the problem. Now, before I get it sent away for reman I had a thought and wanted to see what you guys think...

I can remove the old BSI and pop in a used one. If I were to bypass the immobiliser would a used BSI work??? I've tried bypassing immobiliser and running van without BSI and it runs fine so is there anything else that would prevent a used BSI working.

Any / all thoughts welcome.

No you should be fine running the van, but the configuration may need changing to suit your van, get it on peugeot planet and print the list of options off, then reprogram the new bsi with it, it's easy to break bits, we had a guy who did this and just plugged the bsi in, it was fine until he locked the van, bsi had deadlocking, his locks weren't and it killed the door latches... Be warned to get someone who knows what there doing Wink
Thanks. TBH I cracked my bsi open Friday night just for a nose and it looked fine inside so have sent it away to rollingmotion for inspection / repair. I don't need the van for a few weeks anyway so thought I'd try that route first.

On a related subject I felt the carpet in the drivers footwell and although it felt dry to the touch when I lifted the carpet it was saturated. I got the wet and dry vac in and have removed aprox 3/4 bucket of water from the backing foam and it's still damp. Have took it out to air. After checking windscreen etc it would appear the culprit was leave and crap blocked the drivers side drain hole beneath the wipers. Couple that with the fact the vans been sat facing steeply uphill for about a month and I think we know where the damp connected came from in the first place.

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
M49 1.9 diesel misfire a...
Last Post:jj9
Today 10:51 AM
» Replies: 5
» Views: 134
replacing diesel fuel pip...
Last Post:Col
Today 10:30 AM
» Replies: 36
» Views: 2045
Bump and Run - Am I right...
Last Post:Opensauce
Today 10:26 AM
» Replies: 14
» Views: 213
Dead BSI unit?
Last Post:ghost123uk
Today 09:03 AM
» Replies: 5
» Views: 133
Injectors and B9 series.....
Last Post:Opensauce
Today 06:55 AM
» Replies: 1
» Views: 56
2004 2.0HDi Cruise Contro...
Last Post:brajomobil
Today 06:29 AM
» Replies: 1
» Views: 59
Radio not working and ele...
Last Post:pscotty
Today 04:02 AM
» Replies: 0
» Views: 27
splayed rear wheels
Last Post:jj9
Yesterday 10:36 PM
» Replies: 7
» Views: 112
Dandav1985's Mk3 Berlingo
Last Post:Jed Clampit
Yesterday 10:16 PM
» Replies: 8
» Views: 253
Still on the elusive 4x10...
Last Post:doofer
Yesterday 08:47 PM
» Replies: 3
» Views: 141

Locations of visitors to this page