Thread Rating:
  • 2 Vote(s) - 2.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Windscreen Pump
This is my first real post as I have managed to fix things from looking through previous threads.

My windscreen washer pump does not work, I removed it and tried power straight to the terminals with success. The pump works! Smile

This means there is a problem before the pump Sad and I have no idea where to start, can any point me in the right direction.
First place to look is in the handbook for the fuse that covers the washers. See if it covers anything else and if so is that working. That'll give you a guide. If fuse ok then trace wiring back to switch and check the switch itself.
Ex 1.4 Berlingo Multispace
More than likely the stalk like landmark says
The wipers still work, is that still the stalk?
Yes it's still possible as there's different swithes for the different functions.

Are there 'just' a pump on the tank, or is there a second device there, too?
(An electrically operated valve, used to switch the output from the front to the rear)
No just the one pump, has the two wires coming in the top and one pipe coming out straight to the windscreen. There are no rear wipers.

I will look at the stalk tomorrow after work.

Cheers for the help Smile
hi cookie,,, more than likely its the relay switch,, its built in to the bsi unit and cant be removed from most mk1 models(hope i'm wrong). i had same problem.. i fixed it by putting in a seperate switch on the dash to work the pump,,, i'm 100% certain that in my case it was the relay,.. you should test the wires at the pump with a bulb if you havent a multimeter.
No luck so far so was thinking I might have to add a switch to operate the pump. Cheers for the help guys
I have the same problem, going to take it apart this afternoon.

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Berlingo VTR to ''XTR'' l...
Last Post:david.mckay.3760
Today 01:01 AM
» Replies: 3
» Views: 163
How the heck do I remove ...
Last Post:CourierJim
Yesterday 11:20 PM
» Replies: 7
» Views: 548
Wanted Berlingo / Partner...
Last Post:Matt Haigh
Yesterday 09:41 PM
» Replies: 1
» Views: 72
Storage pods removal How
Last Post:Michael Hills
Yesterday 09:20 PM
» Replies: 0
» Views: 22
Emptying out the cat conv...
Last Post:flashBE
Yesterday 09:12 PM
» Replies: 4
» Views: 217
Cruise control possible o...
Last Post:flashBE
Yesterday 08:58 PM
» Replies: 0
» Views: 28
1.6HDI 75 bigger turbo (f...
Last Post:flashBE
Yesterday 08:52 PM
» Replies: 4
» Views: 145
Timing belt - and accesso...
Last Post:flashBE
Yesterday 08:50 PM
» Replies: 17
» Views: 631
2006 1.6hdi - indicators ...
Last Post:pidgeonpost
Yesterday 08:03 PM
» Replies: 9
» Views: 197
Last Post:harkylad
Yesterday 07:40 PM
» Replies: 0
» Views: 25

Locations of visitors to this page