Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
berlingo 53 van 2.0
hi guys new here, just bought my first berlingo (work van) 2.0 hdi 53 plate 130,000 on the clock. is it normal for glow plug light to not come on? and my horn dont work (not a fuse) any ideas?? thanks in advance.
Hello GmillZ welcome to the forum yes it's normal not to come on i think it's got to be below freezing for it to come on horn not working is a bad earth under the air bag there is an how to on the way to fix it :thumbsup:
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy

Thanks for the reply. okay thats cool about the glow plug light, how do i fix the earth problem? i dont have an owners manual unfortunatly, so any info on how to do get to the airbag would be helpful. i will be having a service on the van, what would be the best oil to use? 5/30, 5/40, 10/40 ? i do know there is an offer coming on oil for £12.50 on tuesday so i dont mind what oil i need. sould i have anything else done at the same time as the service?
Have a read of this thread it should sort your horn problem. Removing the airbag is the fiddly bit but just take your time, it would help if you can get a Haynes manual there is a few pictures to help.
Has the cam belt been changed and at what mileage, If not replaced get it done and change the water pump changed while you are at it.
Good luck with your new motor.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
im not sure if the cam belt has been changed but the van is on 130000 miles. thanks for the replies guys.

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
2004 2.0HDi Cruise Contro...
Last Post:cancunia
Today 05:37 PM
» Replies: 2
» Views: 76
Still on the elusive 4x10...
Last Post:Carl Davis Hulin
Today 05:00 PM
» Replies: 4
» Views: 155
Bump and Run - Am I right...
Last Post:Opensauce
Today 03:19 PM
» Replies: 18
» Views: 288
Eco activated but engine ...
Last Post:Satellitemark
Today 02:57 PM
» Replies: 28
» Views: 795
I'm hearing better or smt...
Last Post:Johny555
Today 02:05 PM
» Replies: 10
» Views: 351
Newbie checking in
Last Post:Johny555
Today 01:57 PM
» Replies: 1
» Views: 25
M49 1.9 diesel misfire a...
Last Post:ricc
Today 01:14 PM
» Replies: 6
» Views: 153
replacing diesel fuel pip...
Last Post:Col
Today 10:30 AM
» Replies: 36
» Views: 2063
Dead BSI unit?
Last Post:ghost123uk
Today 09:03 AM
» Replies: 5
» Views: 147
Injectors and B9 series.....
Last Post:Opensauce
Today 06:55 AM
» Replies: 1
» Views: 70

Locations of visitors to this page