Thread Rating:
  • 2 Vote(s) - 1.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Just saying hello
#1
Hi.
I've just purchased a 2011 Multispace XTR and just want to introduce myself.
Previously had a Qubo and there is a similar site for them which I found useful and at times amusing/entertaining so looking forward to being part of this site. I hired a Berlingo in Spain in 2008 and really enjoyed driving it and always said I would have one here one day. Only had this one a week but already enjoying the extra space and comfort. It does need a couple of things and I've noticed in the forum references to a MK 2 which seems to be an earlier model. Though it might be a dumb question any guidance as to what designation/Mk if any the 2011 is would be greatly appreciated.
Many thanks. Paul
P.s. Hope I've ticked the correct boxes below now wheres the post button
Reply
#2
Hello Paul welcome to the forum good to have you with us it's a MK3 :thumbsup: you will find this you can have some fun on here to along with some good info there are three wise men here Gold frankincense and bull ???
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
[+] 1 user says Thank You to Jed Clampit for this post
Reply
#3
Many thanks for that. Much appreciated.
Reply
#4
Welcome
Former 2011 Mk3 XTR owner Confusedalut:
[+] 1 user says Thank You to taxi for this post
Reply
#5
Hi & welcome.We're mostly sane here,I think.:thumbsup::whistle:
Strawberry flavoured windows  Dodgy
[+] 1 user says Thank You to ron for this post
Reply
#6
Love the avatar.Confusedunny:
Former 2011 Mk3 XTR owner Confusedalut:
[+] 1 user says Thank You to taxi for this post
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Running on chip oil
Last Post:cancunia
Today 09:51 AM
» Replies: 4
» Views: 62
2004 Berlino Aerial
Last Post:malgpz900
Today 09:37 AM
» Replies: 3
» Views: 56
2005 2.0 HDI Siemens pump...
Last Post:cancunia
Today 09:05 AM
» Replies: 1
» Views: 54
1.6 hdi 90bhp Turbo and i...
Last Post:peteh80
Today 06:58 AM
» Replies: 4
» Views: 232
Poor cold startup 1.9
Last Post:Top drive
Today 12:24 AM
» Replies: 40
» Views: 1107
Washers not working
Last Post:Lighty
Yesterday 09:09 PM
» Replies: 11
» Views: 321
Reverse light switch prob...
Last Post:Col
Yesterday 07:22 PM
» Replies: 12
» Views: 285
Fuse is burning all the t...
Last Post:fernandoblas
Yesterday 05:23 PM
» Replies: 12
» Views: 423
HELP! Smashed passenger w...
Last Post:Sootyfoot
Yesterday 04:31 PM
» Replies: 2
» Views: 89
Diagnostic "gear" / Softw...
Last Post:cancunia
Yesterday 04:19 PM
» Replies: 15
» Views: 631

Locations of visitors to this page