Thread Rating:
  • 2 Vote(s) - 2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OBD fault code P0200
#1
Hi Folks,
Wife complained about missfire & eml coming on, so checked fault codes with basic reader and found P0200 - Injector circuit open.
Everything seems connected, just wondering if anyone has had similar and found the cause.
Google throws up so many options.
2002 1.4 Multispace
Cheers,
Griff
Landmark
Ex 1.4 Berlingo Multispace
Reply
#2
got this off the web for you. pitpan

In sequential fuel injection the PCM (Powertrain Control Module) controls each injector individually. Battery voltage is supplied to each injector from, usually, the power distribution center (PDC) or other fused source.




The PCM supplies the ground circuit to each injector by means of an internal switch called a "driver". The PCM monitors each driver circuit for faults. For example, when a fuel injector is commanded "off" by the PCM, it expects to see a high voltage on the driver ground circuit. Conversely, when a fuel injector is commanded "on" by the PCM, it expects to see the voltage pulled low on the driver circuit

If it doesn't see this expected condition on the driver circuit, P0200 or P1222 may set. Other injector circuit fault codes may set as well.

Symptoms

Symptoms of a P0200 DTC may include:
•MIL (Malfunction Indicator Lamp) illumination
•Engine misfire at idle or at highway speed
•Engine may start and stall or not start at all
•Cylinder misfire codes may be present

Causes

Potential causes of an P0200 code include:
•Open or shorted injector
•Injector low internal resistance (basically an injector that works, but is out of specs)
•Grounded driver circuit
•Open driver circuit
•Driver circuit shorted to voltage
•Wiring harness intermittently shorting against underhood components

Possible Solutions

1. If you have multiple misfire/injector codes, a good first step is to unplug all the fuel injectors and then turn the ignition on, engine off (KOEO). Check for presence of battery voltage (12 Volts) at one wire of each injector connector. If all are missing, check for continuity to ground on the voltage circuit by using a test light connected to positive battery and probe each voltage feed. If it lights up, then there is a short to ground on the voltage feed causing a short. Get a wiring diagram and repair the short on the voltage feed and reestablish proper battery voltage. (Don't forget to check for a blown fuse and replace as necessary). NOTE: It's possible for one injector to short out the whole battery voltage feed to all the injectors. So if you have lost voltage to all the injectors, replace the blown fuse and plug each injector in, one by one. If the fuse blows, the last injector you plugged in is shorted. Replace it and retest. If only one or two battery feeds are missing, then it's more likely to be a shorted battery voltage feed in the individual injector wiring harness. Inspect and repair as necessary.

2. If you have battery voltage fed to each injector harness, then the next step is to get a noid light to check for injector driver operation. A noid light will insert into the injector harness in place of the fuel injector and flash rapidly when the injector driver operates. Check each fuel injector connector. If the noid light flashes rapidly then suspect the injector. Ohm each fuel injector if you have a resistance specification. If the injector is open or the resistance is higher or lower than the spec, replace the fuel injector. If the injector tests out, the problem is likely an intermittent wiring problem. (Remember that a fuel injector can work properly when cold but go open when hot, or vice versa. So it's best to do these checks when the problem is occurring). Check the wiring harness for any chafing, or the injector connector for loose pins or a broken lock. Repair as necessary and retest. Now, if the noid light doesn't flash, then there's a problem with the driver or the driver circuit. Unplug the PCM connector and ohm the fuel injector driver circuits. Any resistance means there's a problem. Infinite resistance points to an open in the circuit. Find it and repair it, then retest. If you can find no problem with the harness and there is no fuel injector driver operation, then check the PCM powers and grounds. If they are okay, the PCM may be at fault.
[+] 1 user says Thank You to pitpan for this post
Reply
#3
Hi Pitpan,
Many thanks for that. I've looked in the Haynes manual for the injector wiring diagram but it's not covered. I was looking to check the PCM earth first. Don't suppose you can help on these too please.
Griff
Landmark
Ex 1.4 Berlingo Multispace
Reply
#4
You have a 1.4i ?

The injectors are connected in pairs, so two opens at the same time whenever it fires.
There's 3 wires in the cable going to the injectors, one common and one for each pair.
(Can't remember if the common is 12V or Gnd on these engines, so I'll just assume that what Pitpan posted is correct)
There's a connector somewhere under the inlet manifold and the cable that continues from that splits into 4 connectors that fits onto the injectors.

If you can get the 'split section' out, it's pretty easy to measure it, as one pin(on the 3pin connector) will be connected to the same pin on all 4 2pin connectors, and so on...
You can measure it without disconnecting it in the rear, too(it's a pain to get to the rear connector), as one pin on each of the 4 2pin connectors will be common, and the other pin will have a mate in one of the other connectors.
you should also be able to find the two pairs somewhere on the ECU connector.

Verify that there's a good connection all the way.
(If you search out the 3 pins on the ECU connector, you should be able to measure resistance between the common and each of the 'signal' pins when the injectors are hooked up. You get about half the resistance with both injectors of a pair is hooked up as when only one is connected)

Depending on build, you can have either Bosch or Weber injectors.
They both operate the same way, and even have the same connectors.
(Bosch is thicker, though, so they're not interchangeable)

DO NOT remove the injectors unless you happen to have a new set of seals for them as unles they've been changed recently, they'll not survive the experience.
DO NOT try to remove the High-Pressure reservoir, either, because of same reason.

I bought seals from mrinjectoruk.co.uk
(He also sells filters for them, or reconditioned and tested replacement injectors)
And a final tip, it helps to coat the seals in Dot4 brake fluid before installing injectors.

If you tell us which ECU model you have, we may be able to tell you which pins on the connector goes to the injectors.
Some of the wiring is covered, but in another Haynes book.
(One ofthe 'professional' series covers engine management systems for a whole lot of cars)
Reply
#5
The injectors are fed by a 12v feed from the double relay or psf1 depending on age of the vehicle, for how hard it is to remove the injectors I would try disconnecting single injector plugs one at a time with the engine running, this won't hurt anything, when you get to the correct injector that doesn't change the engine revs then you have zero'd in...

Injectors 1 and 4 are paired with the same driver, as are 2 and 3, if it's injector 2, swap it for number one, that way you know if it's the injector or a supply after repeating the above procedure with the two injectors you've swapped, if it's the same cylinder you know it's the wiring to the injector, if it swaps cylinders then it's the injector....

I have known the rubber encased wiring loom break internally, a set of flashers is handy to see if the driver is firing, it's just a bulb with pins to fit in the plug that normally goes on the injector, but more commonly is whichever injector is situated under the bonnet mounted washer nozzle, Citroen C2 have a common fault with number 3 injector (from the flywheel end as the French do!) dying a premature death, there are modded jets available but silicone sealer under the jet does the trick just aswell...

Hope this helps Smile
Reply
#6
Hi Guys,
thanks for the quick replies. Gadgetman the ECU is marked Sagem.
Griff
Landmark
Ex 1.4 Berlingo Multispace
Reply
#7
It's a sagem s2000 and they are also common for coil packs (only ever replace with genuine pug stuff for the benefit of anyone reading this), but your code indicates an injector fault
Reply
#8
(16-07-2014, 01:41 PM)dumdum Wrote:  It's a sagem s2000 and they are also common for coil packs (only ever replace with genuine pug stuff for the benefit of anyone reading this), but your code indicates an injector fault

Coil pack was replaced with genuine 12 months ago and there is no sign of the windscreen washers leaking.
Landmark
Ex 1.4 Berlingo Multispace
Reply
#9
The Haynes book only lists the Sagem SL96.

There the injectors are controlled from pins 1 and 2 on the ECU.
Common is on pin 4 on the main relay, which you'll fin as a black lump, mounted on the wall in front of the fuse box in the engine compartment.

I don't think the washers are close enough to leak onto the injectors in this engine.

If you have access to LEXIA3, and a mchanic's stethoscope, you could just have it 'exercise' the injectors while you listen to them.
(Actually, you can hear them rattling if there's no other noise nearby, anyway)
Reply
#10
There is another option and that is just to get everything changed, cost a little but at least you have brand new parts. Plus if it happens again soon after you know it's not the new part.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Bottom Ball joint
Last Post:jj9
Today 08:18 PM
» Replies: 5
» Views: 46
peugeot charger
Last Post:geoff
Today 06:35 PM
» Replies: 4
» Views: 113
cutting out HDi 1.6 diese...
Last Post:Col
Today 06:15 PM
» Replies: 18
» Views: 1425
Poor cold startup 1.9
Last Post:Top drive
Today 06:10 PM
» Replies: 34
» Views: 789
hello
Last Post:ron
Today 05:22 PM
» Replies: 1
» Views: 32
Lower Ball Joint
Last Post:brodfather11
Today 03:36 PM
» Replies: 1
» Views: 47
starting problem
Last Post:brodfather11
Today 03:32 PM
» Replies: 1
» Views: 37
Washers not working
Last Post:Redjoe100
Today 03:25 PM
» Replies: 6
» Views: 140
citroen berlingo alarm
Last Post:sks01773
Today 11:28 AM
» Replies: 0
» Views: 33
Reverse light switch prob...
Last Post:ffrenchie
Today 09:48 AM
» Replies: 6
» Views: 107

Locations of visitors to this page