Thread Rating:
  • 1 Vote(s) - 1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] Injectors
#1
If the entrance of the injectors has a brownish residue around each one is this a sign of wear and tear.
[+] 1 user says Thank You to pitpan for this post
Reply
#2
What do you mean by entrance?
Reply
#3
(18-07-2014, 09:05 AM)homeruk Wrote:  What do you mean by entrance?

looking down from behind the coil pack you can see the four injectors, each has a black seal and around this seal is a brownish residue, could this be the oil they used for ease of fitting when they were fitted all those years ago.

Also if I need to change them is it easy to do. I know I have to depressurise the fuel line then remove components to get to the fuel rail, but are there any tips to make it safe and easy to do. removal of the injectors is easy once the fuel rail has been removed and its just a case of changing the injectors with new seals etc.
Reply
#4
Safety tips?
Disconnect battery, stop smoking...
Rags... Lots of rags...

Yeah, it's pretty easy to change them.

Depressurizing the rail(it's actually the 'High Pressure Reservoir') is most easily done with the Schrader valve at the end, if it has one.(Not certain when they started fitting those. My 1999 didn't have one originally) Just place rags underneath first... Oh, and maybe consider waiting half an hour before messing about there afterwards. Sparks and all that.

Remove coil-pack, throttle wire and bracket.
Disconnect fule line(s).
Then the screws holding the HP reservoir in place.
There may be a screw that's in-between the pipes of the inlet manifold and is quite a bother to loosen up. Don't unscrew it completely...
(10mm Hex head. I use a ratcheting wrench where you can twist the handle in addition to the normal back and forth motion. you can barely reach if you stick your arm down behind the end of the reservoir and reach under the inlet manifold)

The injectors are fastened to the reservoir with metal brackets. It is possible to leave them in and pull all 4 injectors out at the same time, but that makes it more difficult to uncouple the cables.

Disconnect the cables from the injectors. Be very careful with the metal spring-clips locking them in place. A *Ping* sound is NOT a fun experience...

The 'brown residue' is probably crud and oil vapour that has collected over the years. Nothing to really get worried about unless it's wet. (Might want to check the seal on the 'breather pipe' going from the camshaft rocker cover to the air filter box. Also the fitting on the air filter box is a weak point)

Dip the new seals in Dot4 brake fluid(most Berlingo owners have a bottle of this somewhere because of the annoying sensor on the brake fluid reservoir... ) to ease fitting.
If you can get a set of filters for the injectors, this would be a good time to replace them.
The old filters can be pulled out with a wood screw.
(This destroys the filters, though, so don't do it unless you have new filters waiting to be installed)

Ordinary rubber O-rings are not suitable replacement seals.
[+] 1 user says Thank You to Gadgetman for this post
Reply
#5
(18-07-2014, 10:24 AM)Gadgetman Wrote:  Safety tips?
Disconnect battery, stop smoking...
Rags... Lots of rags...

Yeah, it's pretty easy to change them.

Depressurizing the rail(it's actually the 'High Pressure Reservoir') is most easily done with the Schrader valve at the end, if it has one.(Not certain when they started fitting those. My 1999 didn't have one originally) Just place rags underneath first... Oh, and maybe consider waiting half an hour before messing about there afterwards. Sparks and all that.

Remove coil-pack, throttle wire and bracket.
Disconnect fule line(s).
Then the screws holding the HP reservoir in place.
There may be a screw that's in-between the pipes of the inlet manifold and is quite a bother to loosen up. Don't unscrew it completely...
(10mm Hex head. I use a ratcheting wrench where you can twist the handle in addition to the normal back and forth motion. you can barely reach if you stick your arm down behind the end of the reservoir and reach under the inlet manifold)

The injectors are fastened to the reservoir with metal brackets. It is possible to leave them in and pull all 4 injectors out at the same time, but that makes it more difficult to uncouple the cables.

Disconnect the cables from the injectors. Be very careful with the metal spring-clips locking them in place. A *Ping* sound is NOT a fun experience...

The 'brown residue' is probably crud and oil vapour that has collected over the years. Nothing to really get worried about unless it's wet. (Might want to check the seal on the 'breather pipe' going from the camshaft rocker cover to the air filter box. Also the fitting on the air filter box is a weak point)

Dip the new seals in Dot4 brake fluid(most Berlingo owners have a bottle of this somewhere because of the annoying sensor on the brake fluid reservoir... ) to ease fitting.
If you can get a set of filters for the injectors, this would be a good time to replace them.
The old filters can be pulled out with a wood screw.
(This destroys the filters, though, so don't do it unless you have new filters waiting to be installed)

Ordinary rubber O-rings are not suitable replacement seals.

Thanks for that gadgetman,
I will have to source new injectors plus seals fire washers ect as they cost a small fortune in Oz so will look online to buy from England and have them posted to me. Do new injectors come with the seals or is that a seperate order.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
temperatue dial
Last Post:sks01773
Today 05:06 PM
» Replies: 2
» Views: 40
Rear hub nut torque setti...
Last Post:Top drive
Today 04:52 PM
» Replies: 14
» Views: 196
New PureTech 110 S&S Flai...
Last Post:Solent
Today 04:35 PM
» Replies: 0
» Views: 12
Trip Computer on Type A M...
Last Post:cancunia
Today 03:50 PM
» Replies: 0
» Views: 13
Loud beeping from radio u...
Last Post:nicko
Today 03:49 PM
» Replies: 3
» Views: 88
Ligts won't go off!
Last Post:Berlingos12
Today 02:50 PM
» Replies: 10
» Views: 445
DW8 engine tapping
Last Post:brodfather11
Today 08:30 AM
» Replies: 1
» Views: 62
Washers not working
Last Post:Luis Rosa
Today 07:47 AM
» Replies: 8
» Views: 222
increase in a ratchet-typ...
Last Post:saskak
Today 12:36 AM
» Replies: 7
» Views: 147
Rear Wiper Motor
Last Post:madwelshman
Yesterday 10:42 PM
» Replies: 3
» Views: 125

Locations of visitors to this page