Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
berlingo clutch pedal play

does anyone have a diagram for a berlingo 2008 1.6 hdi the clutch pedal assembly as my clutch seems to have a lot of play from side to side and when you press the pedal downwards it goes sideways a little, looks like a washer or pivot bush has broken or something, would be handy having a diagram, also the pedal is sqeeky when pressing down and driving me mad!

once i get a diagram i can find the part needed all going well.

many thanks to all.
My pedal was like that when I bought the vehicle ( admittedly a 1.9 ) tightening up the two securing bolts sorted it. Maybe you'll be lucky.
thanks for the info.

2 securing bolts? one bolt and nut at top then a bolt with a clip and the qhole pedal moves sideways so not sure if its a shim etc broken or just needs washers?

Mine has a nut and bolt which passes through the whole pedal unit ( it bolts in as a complete unit ) and a second bolt only which gives the pedal height position / free play. Like I say mine is a 1.9 so may be different to yours but it won't hurt your wallet to check, maybe ten minutes of your time including putting the tools away.
Hi stu, check this thread where I added some info when I fixed the same problem - turned out to be wear on the plastic parts joining the pedal to the cable holder.
The Berlingo I used to own had this problem (I also posted in the thread in the link). I ended up just living with it until I parted with the van and it never got worse.

Sent from my SM-N9005 using Tapatalk
Our Berlingo has this problem, as well. Anyone got a definitive answer??
Not the owner, just the bloke who looks after it.

ALL the owner does is drive it and put fuel in. Rolleyes
mine too .........any answers yet?????????????????????
Took my clutch pedal off, top pivot thin green nylon bush is worn out, anyone got a part number for it
The green bush on my clutch pedal is worn and causing play also, I need to get to a dealer to study the parts diagram. so I am interested if anyone has the part number for this bit also.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Lack of power Then surge ...
Last Post:michaelg
Today 10:34 PM
» Replies: 6
» Views: 197
something new
Last Post:Matt Haigh
Today 10:26 PM
» Replies: 1
» Views: 44
Last Post:ntm1275
Today 09:51 PM
» Replies: 2
» Views: 67
Last Post:ron
Today 07:46 PM
» Replies: 6
» Views: 144
Poor fuel economy.. again...
Last Post:Jane Rushby
Today 06:50 PM
» Replies: 13
» Views: 1409
Where Did you find
Last Post:Jane Rushby
Today 06:26 PM
» Replies: 93
» Views: 165494
Radio needs VIN programme
Last Post:Tomcat3
Today 06:09 PM
» Replies: 3
» Views: 137
Speedo/milometer fault
Last Post:Gixxerguyk8
Today 04:51 PM
» Replies: 10
» Views: 908
Rear reversing sensors
Last Post:tarrymittens
Today 03:55 PM
» Replies: 0
» Views: 37
Heater Matrix replacement...
Last Post:noworries81
Today 01:13 PM
» Replies: 22
» Views: 3751

Locations of visitors to this page