Thread Rating:
  • 3 Vote(s) - 2.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Glow plugs Question
#1
!.9D DW8, 2002

Just removed old glow plugs which were burned out, and replaced with a new set. used my mutlimeter to determine this and a seperate battery test.

I was having cold starting problems for a few weeks and got worse to a point where cold starting was impossible.
after replacing with a new set it starts good again so i decided to test the voltage and to see when it cuts out,, full 12 volts and about 40 seconds later it cut out. but while i left engine running idle 2 minutes later 12 volts cut back in and stayed there for 4 minutes till i stopped the engine...
my question is this,,, 1, is this normal and 2, if its not normal would it have burned out my old glow plugs,, should i consider an internal push switch where i can control the preheating or just leave it alone,,, tnx from ireland,,,joe
Reply
#2
just tested my berlingo again and it looks like the glow plugs come back on after 2 minutes and stays on on the time,,, is it normal
Reply
#3
I've only ever had it where they come on for a fraction of a second and then go off, and they only do that when it is very cold.
2010 (B9) Berlingo Multispace XTR HDi 112 - Kyanos Blue
Previously - 2002 (M49) Berlingo Multispace 2.0 HDi Diesel - Arctic Steel
Reply
#4
No its not normal, and yes it will eventually burn out the plugs. If cold they should come on when starting , and go off after running for a little while. (Post and Pre heating ). There is a relay that controls it somewhere under the battery (I think) which is controlled by the temp sensor which decides if the heating and post heating is necessary and for how long.
[+] 2 users say Thank You to brodfather11 for this post
Reply
#5
tnx guys,, any idea where the temp sensor is located so i can test it.
Reply
#6
the sensor is fitted on the thermostat casing and has a green connector
[+] 1 user says Thank You to brodfather11 for this post
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Heated wing mirrors
Last Post:Bricky Ken
Yesterday 11:57 PM
» Replies: 0
» Views: 16
1.6 hdi 90bhp Turbo and i...
Last Post:Floydster
Yesterday 11:07 PM
» Replies: 1
» Views: 81
how many miles on yours ?
Last Post:Silverberlingo
Yesterday 10:59 PM
» Replies: 17
» Views: 766
1.6 16v petrol cambelt
Last Post:geoff
Yesterday 10:24 PM
» Replies: 5
» Views: 114
Door locking but unlocked
Last Post:DanielEZY0252
Yesterday 09:45 PM
» Replies: 0
» Views: 13
12v for lighter front
Last Post:Jed Clampit
Yesterday 09:07 PM
» Replies: 8
» Views: 185
2.0 HDi fuel issues as pe...
Last Post:G.mk3
Yesterday 07:17 PM
» Replies: 5
» Views: 69
zx1 extralube
Last Post:sks01773
Yesterday 06:07 PM
» Replies: 0
» Views: 42
citroen berlingo desire 1...
Last Post:sks01773
Yesterday 05:57 PM
» Replies: 5
» Views: 135
2012 enterprise berlingo ...
Last Post:Johny555
Yesterday 05:37 PM
» Replies: 9
» Views: 211

Locations of visitors to this page