Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Changed starter - now battery is not charging
#1
After having multiple incidents on my 1.4 petrol Berlingo Mk1 with the starter not working (nothing happening when turning the key) and the solution was (the quite common) hitting it with something, I decided to replace the starter.

The new starter works like a charm, but quite instantly after replacing it the battery warning light started to illuminate. When checking the battery, it reads just around 12V when the engine is running and it looks as if the alternator is broke, but at the same time it seems too much of a coincidence!

So are there any other possible reasons for this to occur? Any easy way of checking? I tried to measure the alternator, but it seems quite difficult to get a good reading from it.

I also realize that it could have been an issue with the alternator in the first place, but I find it strange that the light did not illuminate before I replaced the starter and that the "standard trick" with hitting the starter worked out well.

Any help much appreciated! Wink
Reply
#2
Before you start splashing the cash these coincidences are normally because you have knocked something fitting the new starter or forgot to reattach something.

So first things first check all wiring and check output on alternator.

You can buy alternator tester which makes things easier for a couple of quid.
Reply
#3
Some more investigation leads to believing that the alternator may not be the problem after all...

For some reason, there are several things not working as intended:

- heating for the seats
- heating rear window
- heater
- front lights when light switch is in top position

So could it be as easy as a fuse being blown? Can't find any which looks broken though... Or could it be the BSI going mad?
Reply
#4
Did you do A bsi reset when you disconnected/reconnected the battery?

If not you need to do one , Google is your friend here.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
1.6 16v petrol cambelt
Last Post:cancunia
Yesterday 11:59 PM
» Replies: 13
» Views: 262
Ncb help
Last Post:Jed Clampit
Yesterday 10:32 PM
» Replies: 5
» Views: 152
Saying Hello
Last Post:Jed Clampit
Yesterday 10:25 PM
» Replies: 1
» Views: 28
1.6 hdi 90bhp Turbo and i...
Last Post:Floydster
Yesterday 07:48 PM
» Replies: 3
» Views: 140
Heated wing mirrors
Last Post:Trevor
Yesterday 07:06 PM
» Replies: 3
» Views: 92
2025 Diesel Ban
Last Post:Tree
Yesterday 06:17 PM
» Replies: 15
» Views: 358
Hello
Last Post:Johny555
Yesterday 06:04 PM
» Replies: 1
» Views: 20
Roof noise
Last Post:Veitcast
Yesterday 05:48 PM
» Replies: 0
» Views: 34
Fuel consumption
Last Post:Opensauce
Yesterday 05:37 PM
» Replies: 3
» Views: 57
Lexia clone that works wi...
Last Post:kennard
Yesterday 02:59 PM
» Replies: 58
» Views: 1843

Locations of visitors to this page