Thread Rating:
  • 3 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Knock knock
Hi All,

Just bought an 05 1.9d with 109000 on the clock.

Has had recent timing belt, sump and exhaust.

Was running fine for a week then the other day it started knocking and the engine warning light came on....

When I start the engine it knocks for a bit then clears. Followed shortly by the Engine light coming on. The engine idles smoothly.

Try and pull away and I have to over rev it to stop it from stalling. It also does a big puff of smoke and spat out some black water via exhaust.

There is also a bit of oil? Sitting on top of the manifold at the rear of the head. (I'm assuming rocker cover gasket)

I took it to my local garage and the guy says he can't get it to communicate with the diagnostic kit so I'll have to contact an auto electrician (sounds pricey)

So I guess I'm looking for a steer in the right direction. What to go for first.





Thanks in advance.

Get the timing checked. I bet its also slower than sin. Topping out at about 60 on the flat and struggling to pull its own weight up hills?

Your local garage will have a snap on modus which wont connect to the injection system on this engine, get your self a u480

My injection pump was out of sync (retarded) after a cam belt change ,symptoms were major knock on start up , white smoke , lack of power. Now it pulls like a train ( for a dw8 - i have 2 of them now)

I expect a p0170 code.

How ever i think you also have other issues that im not sure on but getting a u480 and seeing what codes you get would be a start.

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
2006 1.6hdi - indicators ...
Last Post:pidgeonpost
Today 08:03 PM
» Replies: 9
» Views: 190
Last Post:harkylad
Today 07:40 PM
» Replies: 0
» Views: 10
Last Post:Lighty
Today 06:57 PM
» Replies: 3
» Views: 59
Lexia Mods Please..
Last Post:Shelltell
Today 06:36 PM
» Replies: 3
» Views: 49
Front camber out of align...
Last Post:polar
Today 06:31 PM
» Replies: 1
» Views: 27
Electrical Fault
Last Post:Civvic
Today 05:11 PM
» Replies: 1
» Views: 60
Still on the elusive 4x10...
Last Post:Carl Davis Hulin
Today 04:41 PM
» Replies: 0
» Views: 34
Diesel fan in Petrol engi...
Last Post:Johny555
Today 10:34 AM
» Replies: 1
» Views: 43
Wanted Berlingo / Partner...
Last Post:b-f-c
Today 08:32 AM
» Replies: 0
» Views: 58
Eco activated but engine ...
Last Post:brajomobil
Today 08:10 AM
» Replies: 13
» Views: 336

Locations of visitors to this page