Thread Rating:
  • 16 Vote(s) - 3.56 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Rear window Heater
#1
Rear window heater not working. 2002 Multispace with single rear door (tailgate) Haynes manual does not give wiring diagram (only for Pugeot Partner) this shows a relay, is it same for Multispace? if so where is relay located ?
Dash switch seems OK. and window element has continuity. Feed wire has approx. 6V. on it all the time earth OK.
Thanks Pappy
Reply
#2
1) Partner and Berlingo are only "badge engineered" so there are no real differences between them, assume the wiring diagram to be correct.

2) HBoL diagram shows the supply to the relay from the "Passenger Fuse Box". This is to the right of the steering wheel and down. Pull off the cover and you will see it, it does move. Relays are located in here as well and this would be my first place to check
Reply
#3
I mostly agree with Coco about the "Badge Engineering" bit.

Why, in that fine publication and "font of all knowledge" called the Haynes Workshop Manual for Berlingo and Partner are there two separate (clearly identified for each) sets of wiring diagrams for the Berl and Partner???

Not that that book is much use anyhow, still sitting on the fence whether to buy it. If the going gets tough, Mr Haynes uses the catch all clause "Refer vehicle to Citroen/Peugeot Stealer" for anything slightly more complex than fitting a wiper blade or emptying the glove box....
Berlingo Multispace 2.0HDI '54 reg Mediterranean Blue
Reply
#4
Thanks for the replies fellas, the wiring diagrams for Partner and B'lingo are different, fuse nos. do not correspond. Partner diagram shows rear window heater supply from F27. B'lingo F27 supplies Built in systems interface. 30A fuse FC (on built-in systems interface fusebox) is shown as supplying heated rear window this is OK.
I have checked the fusebox below and to the right of the steering wheel but can't see any relays that I could pull out and check. Could the relay have been pulled out? the previous owner had pulled off the connection to the heating element so had had problems. Any suggestions warmly welcomed.
Thanks Pappy.
Reply
#5
check to make sure there is no corrosion on the connections to the rear window.
Somedays you're the pigeon, Somedays you're the statue.
[+] 1 user says Thank You to steve valentine for this post
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
increase in a ratchet-typ...
Last Post:saskak
Today 07:47 PM
» Replies: 5
» Views: 71
Rear hub nut torque setti...
Last Post:geoff
Today 07:31 PM
» Replies: 4
» Views: 75
Heyup
Last Post:polar
Today 07:18 PM
» Replies: 9
» Views: 365
New owner
Last Post:SheilaAnn
Today 04:33 PM
» Replies: 12
» Views: 569
Repair a manual winder wi...
Last Post:Col
Today 04:26 PM
» Replies: 3
» Views: 84
2-Button Key Upgrade
Last Post:Mojow Royle
Today 02:52 PM
» Replies: 1
» Views: 87
Poor cold startup 1.9
Last Post:Top drive
Today 02:46 PM
» Replies: 36
» Views: 878
peugeot charger
Last Post:Jed Clampit
Yesterday 11:28 PM
» Replies: 5
» Views: 179
hello
Last Post:Jed Clampit
Yesterday 11:16 PM
» Replies: 2
» Views: 60
XTR heater control bulb r...
Last Post:VicG
Yesterday 10:57 PM
» Replies: 0
» Views: 46

Locations of visitors to this page