Thread Rating:
  • 3 Vote(s) - 3.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
limp mode after run and switched off for a while
#1
hello all.

i have a 2004/2005 2.0 hdi diesel that runs great, economical, has 'oomph' when needed.

but....

if i drive somewhere and start the engine again after 20 or 30 mins, i get the engine warning light and limp mode.

it is fine if i car is stopped longer, i guess engine has cooled down?

sometimes, a few start and stop of engine fixes the problem, if not i am forced to do an ecu reset..

(ign on, remove battery positive, ign off, touch positive on battery to earth, reconnect positive, wait a few mins, start engine).

anyone have any ideas?

thanks.
Reply
#2
I'd get a code reader on it to see what error messages are showing, if any.
Reply
#3
hi there,

sorry, i meant to add that i did once get a mechanik to read the ecu and it showed clutch switch possible fault and water temp sensor, i changed the water temp sensor and the mechanic suggested it wouldn't hurt to change fuel filter, which i also did.
for a week or so i thought it was fixed, then same issue.
problem is, from my searches on t'internet, even if i do blow 100 quid on a reader, no guarantee it would be of any help as the seimens units are prone to false readings?

i will also add it vary rarely gets used on long runs at speed, something i have since learned is not ideal for diesels.

anyone experienced my actual problem?

ta! sg,
Reply
#4
You need to read the codes,

Your working blind if you don't as it could be any number of things.

You can get a reader off eBay for a tenner which uses an app on your smartphone called torque.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
DW8 engine tapping
Last Post:jj9
Today 01:14 AM
» Replies: 3
» Views: 99
Rear window heater repair
Last Post:Silverberlingo
Yesterday 11:38 PM
» Replies: 0
» Views: 39
New PureTech 110 S&S Flai...
Last Post:Jed Clampit
Yesterday 09:04 PM
» Replies: 3
» Views: 65
What website to pass time...
Last Post:Solent
Yesterday 08:32 PM
» Replies: 0
» Views: 42
Berlingo Parts
Last Post:Sb12
Yesterday 07:56 PM
» Replies: 0
» Views: 42
Rear hub nut torque setti...
Last Post:jj9
Yesterday 07:55 PM
» Replies: 15
» Views: 280
temperatue dial
Last Post:Kokain
Yesterday 05:28 PM
» Replies: 3
» Views: 93
Trip Computer on Type A M...
Last Post:cancunia
Yesterday 03:50 PM
» Replies: 0
» Views: 36
Loud beeping from radio u...
Last Post:nicko
Yesterday 03:49 PM
» Replies: 3
» Views: 126
Ligts won't go off!
Last Post:Berlingos12
Yesterday 02:50 PM
» Replies: 10
» Views: 475

Locations of visitors to this page