Thread Rating:
  • 3 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hedlight trouble
#1
My Berlingo II 1.6 16v 2003 have a nasty habbit of turning off the headlights when it's most needed!
It flickers a few times and then total darkness. It did it for a month ago, then worked ok untill yesterday, then the fault was back. The instrument light and headlight warning lamp still Works when the headlight disappeares, and I don't know if the rear lights disappears too. It comes back on after a few turns of the headlight contact, but turnes off Again a few times, then it just Works for the rest of the day!? I don't think it's the switch itself, as I've been turtning it slightly in all directions when working, without any loss of light.
I cannot see any indication of a headlight relay in the manual, but are there a relay fittet, and if so, where?
I've tried to move all wirering and socketts about, but the light stays on.
Any suggestions??
Reply
#2
The only thing i can think of is a loose or bad earth and check the fuse's are in place when does it happen in the wet or dry or both ?
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
Reply
#3
Untill now it has done so in dry weather. I've checked all wirering connections, and have had the plastic schrowd around the steering Wheel off to check the connections to the light switch, but all seem ok.
Fuses are ok, and have even tried to "wiggle" them a bit, but the light stayed on.
In older cars there was a relay controlling the current to the headlights, but I don't know the system in a Berlingo, but I cannot imagine that full battery power is lead across the switch, so where does it go?
Cannot figure it out, even when I look at the electrical diagram of the car.
At one point I had to brake for traffic, and the light came back on!
It's a mystery to me.
Reply
#4
Also have a light problem.
High beam doesn't work on n/s headlamp, have changed bulbs but still no joy?
Also horn works without ignition on but not when running ?
Reply
#5
(14-12-2014, 10:38 AM)duralinox Wrote:  Untill now it has done so in dry weather. I've checked all wirering connections, and have had the plastic schrowd around the steering Wheel off to check the connections to the light switch, but all seem ok.
Fuses are ok, and have even tried to "wiggle" them a bit, but the light stayed on.
In older cars there was a relay controlling the current to the headlights, but I don't know the system in a Berlingo, but I cannot imagine that full battery power is lead across the switch, so where does it go?
Cannot figure it out, even when I look at the electrical diagram of the car.
At one point I had to brake for traffic, and the light came back on!
It's a mystery to me.

That point's to a loose connection or a bad earth 
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
Reply
#6
(14-12-2014, 08:06 PM)Snarepeg Wrote:  Also have a light problem.
High beam  doesn't work on n/s headlamp, have changed  bulbs but still no joy?
Also horn works without ignition on but not when running ?

Check the earth for that head light foolow the wiring back find the earth point as for the horn a bad earth behind the air bag it's a air bag off job to reconnect the earth wire or earth to the steering column to the body there is a thread here on how to of how to fix the horn
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
Reply
#7
Will check out earth, but if dip works, isn't it the same earth?

The horn, I have read the air bag removal thread and hopefully will sort both problems out.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
DW8 engine tapping
Last Post:jj9
Today 01:14 AM
» Replies: 3
» Views: 92
Rear window heater repair
Last Post:Silverberlingo
Yesterday 11:38 PM
» Replies: 0
» Views: 29
New PureTech 110 S&S Flai...
Last Post:Jed Clampit
Yesterday 09:04 PM
» Replies: 3
» Views: 58
What website to pass time...
Last Post:Solent
Yesterday 08:32 PM
» Replies: 0
» Views: 32
Berlingo Parts
Last Post:Sb12
Yesterday 07:56 PM
» Replies: 0
» Views: 34
Rear hub nut torque setti...
Last Post:jj9
Yesterday 07:55 PM
» Replies: 15
» Views: 270
temperatue dial
Last Post:Kokain
Yesterday 05:28 PM
» Replies: 3
» Views: 84
Trip Computer on Type A M...
Last Post:cancunia
Yesterday 03:50 PM
» Replies: 0
» Views: 32
Loud beeping from radio u...
Last Post:nicko
Yesterday 03:49 PM
» Replies: 3
» Views: 116
Ligts won't go off!
Last Post:Berlingos12
Yesterday 02:50 PM
» Replies: 10
» Views: 474

Locations of visitors to this page