Thread Rating:
  • 1 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Be lingo heater
#1
Hi,
my mothering law has a 58 plate Berlingo done 40k and the heater is not working correctly,the blower works fine but it doesn't heat properly. The heat is fine at speed but if you stop or pull up the heater blows cold when you pull off it starts to work normal, the faster you go the hotter it gets.
It hasn't lost any water and the engine temp is fine.
Any help would be apriciated.
Thanks
Reply
#2
That's a strange one. It sounds that you have a blockage in the water pipes but I don't understand why it would turn cold so quickly. Is the scuttle under the windscreen clear of leaves etc.
--------------------------------------------------------------

2012 Iron Grey XTR 110 with lots of bits and bobs.
Reply
#3
The cable linkage at the heater end can fall off, especially if the pollen filter has been changed, maybe if the flap is loose it may be moving by itself when the air flow changes?

Certainly worth removing the cheek panel and seeing if the linkage moves when the controls are moved.
MkIII VTR 1.6hdi Modutop, Climate Pack, 16" Alloys
Reply
#4
Try bleeding the heater, air in it can partially stop the flow of coolant.
Reply
#5
Thanks for the replys
It's one for the stealers I think.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
DW8 engine tapping
Last Post:Hector Scorn
Today 12:51 AM
» Replies: 2
» Views: 86
Rear window heater repair
Last Post:Silverberlingo
Yesterday 11:38 PM
» Replies: 0
» Views: 15
New PureTech 110 S&S Flai...
Last Post:Jed Clampit
Yesterday 09:04 PM
» Replies: 3
» Views: 54
What website to pass time...
Last Post:Solent
Yesterday 08:32 PM
» Replies: 0
» Views: 27
Berlingo Parts
Last Post:Sb12
Yesterday 07:56 PM
» Replies: 0
» Views: 30
Rear hub nut torque setti...
Last Post:jj9
Yesterday 07:55 PM
» Replies: 15
» Views: 260
temperatue dial
Last Post:Kokain
Yesterday 05:28 PM
» Replies: 3
» Views: 73
Trip Computer on Type A M...
Last Post:cancunia
Yesterday 03:50 PM
» Replies: 0
» Views: 25
Loud beeping from radio u...
Last Post:nicko
Yesterday 03:49 PM
» Replies: 3
» Views: 110
Ligts won't go off!
Last Post:Berlingos12
Yesterday 02:50 PM
» Replies: 10
» Views: 470

Locations of visitors to this page