Thread Rating:
  • 3 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ECU nightmare, please help!
#1
Hi, Im hoping someone one here maybe able to help me Im having a nightmare with my 2004 1.9 diesel Berlingo van. The long and short of it is that it was smoking heavily and the engine management light came on along with many other lights, this has been on and off for a year, usually it resets itself and runs fine again but not this time.

Took it to the garage they told me that there was a problem with the ECU. they gave me two options, send off my ECU for repair (its Lucas which alot of companies wont touch) or buy a secondhand unit from an identical vehicle with the same codes etc which I have for £80, have new key fobs and all the components.

I now pay the garage to fit the new ecu and all the other parts, it wont start, they now tell me that the new ECU wont recognize the fuel pump. They tell me they can sent it to my local Citroen dealer Yeomans to have the fuel pump coded, after another £85 they tell me its not possible?, So I pay the garage yet more money to remove the new ECU and all the bits and replace it with the old one so at least I can move the van leaving a massive smoke cloud behind me!.

The man I brought the new ECU claims there nothing wrong and tells me he has the matching fuel pump which should work, I tell this to the garage who tell me there is no guarantee it will as they are not sure if Citroen wiped the old one? and apparently its a big job to the fuel pump?

I have since spoken to several ECU companies, some tell me that Lucas ECU are not possible to fix and some tell me that they can swap some parts from my new ECU to the old to make it work at more cost. Im about £400 in so far I like my little van and would like to keep him running but am not made of cash, if I can get it going for a few hundred more im in if not its going to the crusher, seems crazy that a perfectly good van can be made redundant by an ECU problem.

Im hoping someone may be able to give me some honest advice or maybe has first hand experience of this problem or some wise suggestions.

Thank you in advance

dave
Reply
#2
When you say it was very smokey what colour was it white

Also when you change ecu set you need to change the chip on pump to match
Reply
#3
(17-12-2014, 04:20 PM)dave3112 Wrote:  The man I brought the new ECU claims there nothing wrong and tells me he has the matching fuel pump which should work, I tell this to the garage who tell me there is no guarantee it will as they are not sure if Citroen wiped the old one? and apparently its a big job to the fuel pump?

It seems that Lucas ecu is really a nightmare Sad I have checked other forums...

I would go this way. Use the new ecu from the new man and also that fuel pump.
Fit it to blingo and try. I bet that citroen dealer didn't erase the original pump. That is why they told you
it could not be done... I would go to another garage to fit the new ecu and pump. Not close by, just to 
be sure if every body is telling the truth.

Best regards,
brajomobil
Reply
#4
The thing is the ecu is so simple on these vans my money is there is nothing wrong with ecu. If it is white smoke I would say damage to fly wheel or crank sensor both mean not picking up signal. Has happened to me easy to know is the Rev counter working

People blame ecus to often when they don't understand bought a car before suspected ecu fault doing mad things and was bad earth
Reply
#5
Hi thanks for you help so far, the smoke is a grey rather than steamy and very strong diesel taste to it, when the fault used to occur intermitantly the rev counter would drop off and stop working and the bat light would come on and strangely the heaters/blowers would stop working when the van was stationary. The mechanics said it was the ECU partly due to the fact that they could disconnect the crank sensor and the van would still run, apparently this should not happen
Reply
#6
I would say it was something the crank sensor because when you disconnect it you will lose rev counter and there is 2 tabs on the flywheel to refine the fuel

so I would say faulty crank sensor or something with fly wheel the tabs can brake. my dad done a clutch on one before and clutch bearing smashed the box and one the tabs it then did not run right white/grey smoke and running lumpy
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
2-Button Key Upgrade
Last Post:Mojow Royle
Today 02:52 PM
» Replies: 1
» Views: 78
Heyup
Last Post:Mojow Royle
Today 02:49 PM
» Replies: 8
» Views: 350
Poor cold startup 1.9
Last Post:Top drive
Today 02:46 PM
» Replies: 36
» Views: 862
Rear hub nut torque setti...
Last Post:El Berlingo
Today 01:14 PM
» Replies: 3
» Views: 62
peugeot charger
Last Post:Jed Clampit
Yesterday 11:28 PM
» Replies: 5
» Views: 173
hello
Last Post:Jed Clampit
Yesterday 11:16 PM
» Replies: 2
» Views: 58
XTR heater control bulb r...
Last Post:VicG
Yesterday 10:57 PM
» Replies: 0
» Views: 41
Fuel consumption
Last Post:ron
Yesterday 09:41 PM
» Replies: 12
» Views: 310
Rear Wiper Motor
Last Post:minisandfords
Yesterday 08:48 PM
» Replies: 2
» Views: 97
Lower Ball Joint
Last Post:brodfather11
Yesterday 08:38 PM
» Replies: 2
» Views: 106

Locations of visitors to this page