Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Coolant temperature rising too fast warning light problem
#1
I have a 2005 2.0L Diesel Desire and over the past month I have started to have a problem with the red coolant temperature rising too fast warning light coming on. When it does so the alert beep sounds and the big red STOP warning lights up. It is intermittent but becoming more frequent. It has gone from a couple of times a week to several times a day (but not every day!). It only happens in the first few minutes after starting the engine from cold and only lasts a few seconds before clearing. Today was the worst it has been, repeating several times and persisting after I had pulled over and restarted the engine several times. Does anyone have any suggestions? It's difficult to ask for a repair without being able to demonstrate the issue. Could it be a faulty sensor
and so safe to ignore? Or a faulty valve and so potentially catastrophic for the engine? Thanks for any help you can offer :-)
Citroen Berlingo 2.0 HDi Desire 2005
Reply
#2
When I had a similar problem a new sensor fixed it for me.

Tony
Reply
#3
Thanks - is it a tricky job or expensive to have a garage do for me?
Citroen Berlingo 2.0 HDi Desire 2005
Reply
#4
This this thread:

http://www.berlingoforum.co.uk/thread-3693.html

The most difficult bit is removing the clip which is fiddlely, obviously when you remove it the coolant will leak out so some mechanical skills are required.

Tony
Reply
#5
(13-01-2015, 09:55 AM)tc_1 Wrote:  This this thread:

http://www.berlingoforum.co.uk/thread-3693.html

The most difficult bit is removing the clip which is fiddlely, obviously when you remove it the coolant will leak out so some mechanical skills are required.

Tony

Thanks again.

The problem is definitely getting worse and seems to occur more frequently on very cold days. On the drive home this evening I had so suffer four or five bursts of bleeping and flashing red lights. It's still only ever in the first few minutes after starting up. As soon as the temperature guage needle starts to rise up from the bottom as the engine warms then the problem goes away.

Am I ok to ignore the warning whilever the temperature gauge is not showing the engine running hot? The temperature appears to rise gently from cold as normal and isn't running any hotter once up to temp than it ever has done over the past 10 years.
Citroen Berlingo 2.0 HDi Desire 2005
Reply
#6
(14-01-2015, 07:10 PM)petet66 Wrote:  
(13-01-2015, 09:55 AM)tc_1 Wrote:  This this thread:

http://www.berlingoforum.co.uk/thread-3693.html

The most difficult bit is removing the clip which is fiddlely, obviously when you remove it the coolant will leak out so some mechanical skills are required.

Tony

Thanks again.

The problem is definitely getting worse and seems to occur more frequently on very cold days. On the drive home this evening I had so suffer four or five bursts of bleeping and flashing red lights. It's still only ever in the first few minutes after starting up. As soon as the temperature guage needle starts to rise up from the bottom as the engine warms then the problem goes away.

Am I ok to ignore the warning whilever the temperature gauge is not showing the engine running hot? The temperature appears to rise gently from cold as normal and isn't running any hotter once up to temp than it ever has done over the past 10 years.

I personally would sort it.At least you'll know it won't cause other problems.
Strawberry flavoured windows  Dodgy
[+] 1 user says Thank You to ron for this post
Reply
#7
Have you checked the coolant level to make sure it's up to the mark when cold ? also the wiring from the sensor for corrosion
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
[+] 1 user says Thank You to Jed Clampit for this post
Reply
#8
I am going to sort it and soon - I was just meaning whether I can go to work tomorrow or straight to a garage.

I have checked the levels more than once and they seemed ok to me. I haven't checked the wiring but will do :-)
Citroen Berlingo 2.0 HDi Desire 2005
Reply
#9
I'd try cleaning the sensor wiring contacts and a blast of servisol first, if that doesn't cure it, a new coolant sensor. Next I would be looking at new thermostat (it could be failing to open quickly enough) and if the coolant hasn't been changed in the last 3 years, new quality coolant too (50/50 mix) giving the rad a good flush through too incase it's partially blocked.
[+] 1 user says Thank You to jonnie100 for this post
Reply
#10
Thanks to everyone for your advice - I got my local garage to change the sensor on Thursday and so far no warnings so it looks like you cracked it. Thanks again :-)

Somewhat bizarrely I had a problem with the nearside rear door lock not responding to the central locking (see my other thread) and it has now started working again since the sensor was changed... I have no explanation! :-)
Citroen Berlingo 2.0 HDi Desire 2005
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Repair a manual winder wi...
Last Post:AbneyTeal
Today 12:25 PM
» Replies: 0
» Views: 2
Fuel consumption
Last Post:Wyvern
Today 11:18 AM
» Replies: 6
» Views: 92
12v for lighter front
Last Post:nicko
Today 11:09 AM
» Replies: 16
» Views: 340
1.6 16v petrol cambelt
Last Post:sks01773
Today 10:56 AM
» Replies: 14
» Views: 324
lubricating door
Last Post:sks01773
Today 10:52 AM
» Replies: 3
» Views: 97
how many miles on yours ?
Last Post:Wyvern
Today 10:27 AM
» Replies: 18
» Views: 814
Roof noise
Last Post:Opensauce
Today 09:59 AM
» Replies: 2
» Views: 70
Rear light Cluster
Last Post:Opensauce
Today 09:50 AM
» Replies: 3
» Views: 93
Saying Hello
Last Post:ghost123uk
Today 09:07 AM
» Replies: 2
» Views: 48
Lexia clone that works wi...
Last Post:brajomobil
Today 08:02 AM
» Replies: 59
» Views: 1863

Locations of visitors to this page