Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
mileometer, speedo?
#1
Hi,picked van up from airport last night and speedo and mileage display stopped working,would I be right in my old farts assumption that unlike the good old days it won't be a speedo cable nowadays :-)...........

Oh,and if it's a help to a possible cause,it's not as sharp as usual,the goes all but gone,would the two be linked as when first leaving airport it was as quick as ever,then speedo and digital mileage stopped and it's like limp mode but no warning lights,no noises or smoke etc?? 
[Image: smokingdog-1.gif]

Berlingo First,75bhp 1.6hdi,58 plate....225k and counting.
Reply
#2
As a fellow old fart,it sounds like an earthing/electrics prob as you rightly assume there is no cable.Oh for the simple life.What was wrong with steam? Big Grin
Strawberry flavoured windows  Dodgy
Reply
#3
Does some of the engine management work of work off the speedo reading that's why it's gone in to limp mode ?
There's nothing  wrong with steam i usually steamed on a Saturday night and i have an old boiler  Smile
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
[+] 1 user says Thank You to Jed Clampit for this post
Reply
#4
I'm having the speed sensor on top of gearbox replaced Saturday,guy at Citroën told him it's a common fault,he wouldn't say if it could be connected to the power delivery but it sends a signal to bsi unit (what ever that is) so maybe so,I'll post back when I know anything,ta for the replies.Ian.
[Image: smokingdog-1.gif]

Berlingo First,75bhp 1.6hdi,58 plate....225k and counting.
Reply
#5
Fitted the new sensor,all back working,now I can relax..........and breathhhhhhh :-)
[Image: smokingdog-1.gif]

Berlingo First,75bhp 1.6hdi,58 plate....225k and counting.
Reply
#6
Smile  Glad you have it sorted not to much money i hope
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
Reply
#7
£80 and it'll go through my books,it has to be done though :-)
[Image: smokingdog-1.gif]

Berlingo First,75bhp 1.6hdi,58 plate....225k and counting.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Repair a manual winder wi...
Last Post:AbneyTeal
Today 12:25 PM
» Replies: 0
» Views: 3
Fuel consumption
Last Post:Wyvern
Today 11:18 AM
» Replies: 6
» Views: 94
12v for lighter front
Last Post:nicko
Today 11:09 AM
» Replies: 16
» Views: 340
1.6 16v petrol cambelt
Last Post:sks01773
Today 10:56 AM
» Replies: 14
» Views: 324
lubricating door
Last Post:sks01773
Today 10:52 AM
» Replies: 3
» Views: 97
how many miles on yours ?
Last Post:Wyvern
Today 10:27 AM
» Replies: 18
» Views: 814
Roof noise
Last Post:Opensauce
Today 09:59 AM
» Replies: 2
» Views: 70
Rear light Cluster
Last Post:Opensauce
Today 09:50 AM
» Replies: 3
» Views: 93
Saying Hello
Last Post:ghost123uk
Today 09:07 AM
» Replies: 2
» Views: 48
Lexia clone that works wi...
Last Post:brajomobil
Today 08:02 AM
» Replies: 59
» Views: 1863

Locations of visitors to this page