Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] Injector
Hi all,

I have an issue with 1 of my injectors. The last one on the right is all wet (other 3 are fine). I had the injector seals done 2 years ago and also changed the leak off pipe.

Would you know what else would be causing this?

Thank you

Which engine?

Any chance of a picture?

Its the 1.6 HDI engine.

I haven't got that car on me today so will try to take a picture tonight.
Its all wet around/on the injector.

When driving home last night the car suddenly started sounding rougher, Just seems to be knocking more than usual now.



please find attached some pictures.

It seems to get louder as well when it warmer.

Thank you


Attached Files Thumbnail(s)
Sad  Sorry to say i think the seal on No 4 need's doing again you can try to retorx to 25 NM get it done ASAP as it will not do the oil in the engine any good
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy

Sorry took so long to get back to you but missed you repost!

Yes from your picks i would say injector seal! However dont get to hung up on 25NM torque i always do them TIGHT without breaking anything - use your feel and common sense.
Were the injector pipes replaced as well ? It looks like they are leaking round the unions and they are single use according to the manual. The diesel escaping from the injectors can't get into the engine oil only if it is getting past the rings.
So where does this bit go then ?
Thanks all. I have having the injector recon'd this week. Hopefully they will give me new seals.
Does anybody know the part number for the pipes?


The local injector specialist has taken it apart and was surprised it wasn't leaking more. he said the ball in it was all pitted and there are replacement insides coming and i should get it back tomorrow.


Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Construction of Modified ...
Last Post:quangongzi
Today 01:21 AM
» Replies: 0
» Views: 2
Dead BSI unit?
Last Post:Jed Clampit
Yesterday 10:18 PM
» Replies: 2
» Views: 24
Black Smoke
Last Post:Jed Clampit
Yesterday 10:07 PM
» Replies: 3
» Views: 79
Strange exhaust blowing n...
Last Post:dieselj
Yesterday 10:00 PM
» Replies: 1
» Views: 32
My Berlingo Camper build....
Last Post:Jed Clampit
Yesterday 09:58 PM
» Replies: 8
» Views: 353
DPF Regeneration
Last Post:Jed Clampit
Yesterday 09:46 PM
» Replies: 4
» Views: 67
New Battery
Last Post:Jed Clampit
Yesterday 09:35 PM
» Replies: 3
» Views: 65
Window mechanism replacem...
Last Post:Kez
Yesterday 09:01 PM
» Replies: 2
» Views: 59
2012 berlingo radio setti...
Last Post:Matt Haigh
Yesterday 08:37 PM
» Replies: 9
» Views: 203
Air Vent Directors Loose
Last Post:doofer
Yesterday 08:19 PM
» Replies: 2
» Views: 199

Locations of visitors to this page