Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
towbar wiring
#1
Got a new 75hp l1 berlingo 2 weeks ago. Got a bosal towbar bolted it on grand last night. Now trying to wirer up the light socket with the relay. Read the posts here first, looked straight forward enough, took off the left hand panal and find feck all connectors just wires going to the lights and one lot with a joiner going to the middle brake light. No heavy white wire thats the power for the relay unit and no rh indicator wire. The earth is there alright . I was thinking of running a power wire under the floor cover from the power socket on the rhs. Anyone seen this or have citroen done some cut back on the wiring to save a couple of pennys
Reply
#2
I can't help you with the wring of the electrics as I bought the genuine Citroen loom for about £126, but I can say that the power socket on the rhs only works when the ignition is on, so not really suitable.

If you don't have the thick white wire and socket behind the rear left panel, you can get permanent power from a socket in the fuse box behind the glove box

Permanent live fitted as standard to some models - marked as no.1 in the picture
[Image: livefeed.jpg]

If you don't have the cable and socket in picture 1, you can lay your own and connect it to where the cable in picture 1 would connect in to the fuse box behind the glove box
[Image: glovefuse.jpg]

To get live to the socket, you need to put a 40amp maxi fuse in to the fuse box in the engine compartment. The top of the fuse box needs to be lifted up to reveal the maxi fuses
[Image: fusebox.jpg]
[+] 1 user says Thank You to ntm1275 for this post
Reply
#3
Thanks Ntm. Nothing on the lhs just the loom going to the lhs lights. Anyway i brought 3 wires from the rhs to lhs. One for rhs indicator one for rhs tail light and one for power from the socket. You are right not a permanent supply but is this nescessary? The unit beeps every time i turn on the ignition. Maybe im wrong but i would have tought it better not have it powered up all the time. If necessary i will run a new power wire from the fuse box. Anyhow all is working perfectly now and the unit beeps while indicating with the lights pluged in. I was also able to thread the 3 wires tru the box frame over the rear doors so no wire are exposed in the back and they are inside. Thanks again for taking the trouble to reply.
Reply
#4
Glad you got it working OK.

I was lazy and bought the genuine Citroen loom which is just plug and play - more expensive mind you

The reason I said that the power socket may not be suitable is that if you stop the car/trailer/caravan etc and want to leave the side lights on, the trailer/caravan lights will go out when the ignition is turned off
Reply
#5
Ah yeah i see. I won't be towing a caravan just a trailer on occasions. So should be find the way it is. Thanks again
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Head gasket failure.
Last Post:Civvic
Today 08:08 PM
» Replies: 13
» Views: 330
At last
Last Post:Gerald Bostock
Today 08:06 PM
» Replies: 9
» Views: 299
Conversion from manual to...
Last Post:Civvic
Today 07:58 PM
» Replies: 1
» Views: 71
Rear seats
Last Post:Kevin Crisp
Today 05:17 PM
» Replies: 0
» Views: 34
12v for lighter front
Last Post:Matija Danko
Today 05:03 PM
» Replies: 3
» Views: 94
2012 enterprise berlingo ...
Last Post:Col
Today 05:01 PM
» Replies: 4
» Views: 89
Lexia clone that works wi...
Last Post:kennard
Today 04:42 PM
» Replies: 57
» Views: 1777
Water Heater - Glow Plug ...
Last Post:jj9
Today 04:30 PM
» Replies: 19
» Views: 527
Eco mode
Last Post:ghost123uk
Today 04:28 PM
» Replies: 21
» Views: 13772
2025 Diesel Ban
Last Post:dumdum
Today 02:46 PM
» Replies: 1
» Views: 49

Locations of visitors to this page