Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] 1.9d citroen berlingo loads of issues
#1
Hi everyone I have a 1.9d Citroen berlingo multispace owned it for some time now. Bought it with a few problems needed the valve gasket doing and new wishbones and Gave it a service about 9 months ago and just passed a MOT. I enjoy working on my cars so would like to know if I can sort the problems out myself. I've never owned a desiel so bit stuck.

Since the MOT I now have loads of problems with the engine I'm hoping you could help me with them Smile.

The first problem I have is it has stopped starting in the morning. I find if I jump it with another car it's starts a bit easier but still has problems, tested the battery and that's okay but thats as far as I have got.

Today I was driving along and it started to over heat and steam came from the bonnet pulled over to see what was going on. I opened my bonnet and checked everything. There is oil in the coolant tank which wasn't there yesterday and the radiator was cold so assume that the thermostat has gone but can't figure out why there's oil in the coolant tank. Theres no water on the dip stick nor the oil cap So I assume it's not the head gasket.

The last thing is I've started losing power steering fluid....

Thanks in advance if you can give me any solution for any of the problems

Josh.
Reply
#2
It sounds as though the t/stat has stuck closed causing local overheating so it may well be the head gasket.Sorry. Sad Sad
Strawberry flavoured windows  Dodgy
Reply
#3
I was thinking the same but was hoping it was the oil which is okay so must be the head Sad gutted, how straight forward is a engine change in a berlingo, I've changed a engine in a corsa and golf that was pretty straight forward apart the clutch sticking
Reply
#4
There are two other thing's stopping it from starting the starter motor may be getting on a bit so it's not cranking fast enough the other is how many mile's as the old girl done if it's around a 100,000 the valve's gap's close up on the cam so there not full closed so losing compression . The oil in the header tank could also be from the oil cooler having a split / hole and the oil pressure forcing oil into the water ?
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
Reply
#5
(26-01-2015, 11:29 PM)Jed Clampit Wrote:  There are two other thing's stopping it from starting the starter motor may be getting on a bit so it's not cranking fast enough the other is how many mile's as the old girl done if it's around a 100,000 the valve's gap's close up on the cam so there not full closed so losing compression . The oil in the header tank could also be from the oil cooler having a split / hole  and the oil pressure forcing oil into the water ?

I was thinking the valves could be the issue is got 160000 on the clock and the starter motor is brand new so I now it's not that. Think I'm just going to stick it back where it came from before things get worse (Auction!!)
Reply
#6
Sad  Shame you must of picked a bad one don't let it put you off some thing to look for when you look at the next one  Smile
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
2-Button Key Upgrade
Last Post:Mojow Royle
Today 02:52 PM
» Replies: 1
» Views: 78
Heyup
Last Post:Mojow Royle
Today 02:49 PM
» Replies: 8
» Views: 350
Poor cold startup 1.9
Last Post:Top drive
Today 02:46 PM
» Replies: 36
» Views: 862
Rear hub nut torque setti...
Last Post:El Berlingo
Today 01:14 PM
» Replies: 3
» Views: 61
peugeot charger
Last Post:Jed Clampit
Yesterday 11:28 PM
» Replies: 5
» Views: 173
hello
Last Post:Jed Clampit
Yesterday 11:16 PM
» Replies: 2
» Views: 58
XTR heater control bulb r...
Last Post:VicG
Yesterday 10:57 PM
» Replies: 0
» Views: 41
Fuel consumption
Last Post:ron
Yesterday 09:41 PM
» Replies: 12
» Views: 310
Rear Wiper Motor
Last Post:minisandfords
Yesterday 08:48 PM
» Replies: 2
» Views: 97
Lower Ball Joint
Last Post:brodfather11
Yesterday 08:38 PM
» Replies: 2
» Views: 106

Locations of visitors to this page