Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Electrical Issue Dashboard, Indicators Radio
Driving home yesterday in the dark, suddenly the dashboard lights started to flicker and the radio stopped working. Initially I could use the indicators but then they stopped working. Then Dashboard lights would go out completely and then come on for a few seconds and then ceased to work at all.
Current situation is that Dashboard lights, Indicators, Radio are non functioning but the dashboard warning lights, driving lights and engine (ignition) work perfectly.
Does not sound like a fuse because of the way it developed but does anyone know of any wiring harnesses that might be chafing or maybe where wires get loose on Berlingos. This is a 1.8 petrol circa 2001.
Before indicators stopped working, (but while dashboard was coming on and going off), they made a purring noise. It was as if the full whack of electricity was not getting to them.
Otherwise car runs perfectly.
Just remembered something else odd recently. One in 50 drives, if I turn the engine off but leave headlights on, they wont switch off. by using stalk control. Cure is to turn ignition off and on without starting engine.
Do I perhaps have a general Control unit (BSI?) issue? Clutching at straws I know.
This may be a fluke, but a few years back the dealer loaned me a Berlingo same as yours whilst mine was in and it had the same faults as you describe, including the heater fan not working. However, I found that if you really revved it through the gears, everything started to work again until you turned the engine off. Yes, I know this sounds daft, but it's true. Don't know what difference the hard driving made, but it worked. However, as I only had the car for an afternoon, it wasn't a problem, although I did tell the dealer when I took it back.
2014 Berlingo Multispace 1.6 e-Hdi XTR ETG6
Sounds like a poor connection in the BSI.
[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]
[+] 1 user says Thank You to Ol'Jeffers for this post
Or alternator regulator brushes going noisy and spiking the supply.
Mar 2002 Berlingo Multispace Forte 1.9D 166,000 miles

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Checking how much DPF Add...
Last Post:ntm1275
Yesterday 11:40 PM
» Replies: 3
» Views: 63
Rear reversing sensors
Last Post:tarrymittens
Yesterday 10:01 PM
» Replies: 2
» Views: 108
Blingo Help Please
Last Post:jj9
Yesterday 09:30 PM
» Replies: 12
» Views: 1276
Berlingo mk3 B9 airbag re...
Last Post:Jed Clampit
Yesterday 07:19 PM
» Replies: 1
» Views: 198
Removing Fuel tank/ sende...
Last Post:michaelg
Yesterday 06:46 PM
» Replies: 2
» Views: 49
DPF Regeneration
Last Post:Opensauce
Yesterday 06:42 PM
» Replies: 5
» Views: 146
I'm hearing better or smt...
Last Post:andy-M
Yesterday 05:26 PM
» Replies: 5
» Views: 233
M49 1.9 diesel misfire a...
Last Post:divingdad
Yesterday 04:59 PM
» Replies: 1
» Views: 49
Last Post:Jane Rushby
Yesterday 04:01 PM
» Replies: 7
» Views: 185
Strange exhaust blowing n...
Last Post:Landmark
Yesterday 03:51 PM
» Replies: 3
» Views: 111

Locations of visitors to this page