Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] Really annoying hesitation between 50 - 60mph
#1
Hi All,

Please help me because I don't want to get cross.

My brill little 2006 1.9d has done 82k and recently had a major service replacing everything that needed to be. Before it went in it was running OK but needed some attention because it had just started to hesitate when pootling down the by-pass between 50-60 depending on traffic. It feels like the throttle is shut off suddenly, hesitating for a moment (maybe 1-2 secs) then carries on.  After the service it started hesitating more frequently, always between 50-60. Yesterday I had a terrible hammer drill noise (knock?) while it was busy hesitating. Funny I thought. 

There's no engine warning lights so started paying attention to when it happens. Always on slight inclines, when carrying large ladders on the roof bars against the wind or when trying to stay at steady speed. I can push the throttle down harder and and bust through it or back off completely and have to accelerate again.  It accelerates up through the gears fine and I can wallop the old girl in 4th up a couple hills near me at 65mph. I took it back to the garage and they looked for fault codes, nothing, they also thought it might be a poor fuel filter so they replaced it again but frankly they're fitters not mechanics and have washed there hands of it. I thought I'd do a bit of investigating and I found the bottom of the air intake resonator between the maf and egr was split so I got a replacement but its still hesitating. I ran an egr cleaning solution through and got lots of black soot out the back but its still hesitating. I unplugged the maf and tried running it but it was horrible so I quickly plugged it back in, I've done a BSi reset ... same problem, I've cleaned every connector, there's no weeping from the injectors ... you get the picture.  It starts first time every time, returns 40mpg, there's no smoke, pootles round at 30-40 brilliantly it just when I want a bit more.

I just skimmed through 51 pages in the forum and I can't find a thread ... has anyone had a similar problem?

No, its no good, I'm getting very cross.
Reply
#2
Not familiar with that eng but has the MAF a sensor wire that can be cleaned?
Strawberry flavoured windows  Dodgy
Reply
#3
An intermittent juddering or misfire can be symptomatic of impending turbocharger failure. The first time this happened to me the turbo disintegrated and seized the engine (luckily under warranty). The second time I thought I was having fuel injector problems, but actually a refurbished turbo (£350) totally fixed the problem. I'd definitely explore the turbo as a potential source of your problem.
Reply
#4
(03-02-2015, 11:43 PM)CourierJim Wrote:  An intermittent juddering or misfire can be symptomatic of impending turbocharger failure. The first time this happened to me the turbo disintegrated and seized the engine (luckily under warranty). The second time I thought I was having fuel injector problems, but actually a refurbished turbo (£350) totally fixed the problem. I'd definitely explore the turbo as a potential source of your problem.
The 1.9 doesn't have a turbo,that's why it's slow.
Strawberry flavoured windows  Dodgy
[+] 2 users say Thank You to ron for this post
Reply
#5
Hi Ron, yes the maf sensor body has an 8-way connector with 5 contacts used. I unplugged cleaned and replaced this. I haven't touched the airflow sensor.

There's no turbo
Reply
#6
(04-02-2015, 12:05 AM)tomsk Wrote:  Hi Ron, yes the maf sensor body has an 8-way connector with 6 contacts used. I unplugged cleaned and replaced this. I haven't touched the airflow sensor.

There's no turbo

You can buy a cleaner to clean the sensor just remember it's delicate.
Strawberry flavoured windows  Dodgy
Reply
#7
I've just had a look for some. There's some LiquiMoly stuff on Amazon for £15. Its the only make I've heard of. Have you tried any of them?
Reply
#8
I've just cleaned the MAF using an electrical cleaner and was surprised by the amount of black soot that came off the sensors. Put it all back together but still no joy.

I've ordered a diagnostic tool, see what I can see.
Reply
#9
Tomsk.Did you find your problem? I would like to know the outcome,being the nosey bugger that I am. Wink
Strawberry flavoured windows  Dodgy
Reply
#10
(08-08-2015, 09:09 PM)ron Wrote:  Tomsk.Did you find your problem? I would like to know the outcome,being the nosey bugger that I am. Wink

No I never did. It began to cost me a lot at various diesel specialists so I sold it about 5 weeks ago.
The chap that bought it said only thing left to replace was the fuel pump and as that costs more than the can was worth he was welcome to it.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Door locking but unlocked
Last Post:ricc
Today 10:08 AM
» Replies: 2
» Views: 34
12v for lighter front
Last Post:ffrenchie
Today 09:56 AM
» Replies: 9
» Views: 212
Rear seats
Last Post:doofer
Today 09:55 AM
» Replies: 1
» Views: 67
2025 Diesel Ban
Last Post:doofer
Today 09:52 AM
» Replies: 10
» Views: 210
1.6 hdi 90bhp Turbo and i...
Last Post:Trevor
Today 09:46 AM
» Replies: 2
» Views: 94
lubricating door
Last Post:sks01773
Today 08:57 AM
» Replies: 0
» Views: 23
Heated wing mirrors
Last Post:3rensho
Today 06:00 AM
» Replies: 1
» Views: 40
how many miles on yours ?
Last Post:Silverberlingo
Yesterday 10:59 PM
» Replies: 17
» Views: 779
1.6 16v petrol cambelt
Last Post:geoff
Yesterday 10:24 PM
» Replies: 5
» Views: 139
2.0 HDi fuel issues as pe...
Last Post:G.mk3
Yesterday 07:17 PM
» Replies: 5
» Views: 79

Locations of visitors to this page