Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] Oil Pressure Insuffcient
Hi all,

My berlingo 2006 1.6hdi has just started showing 'oil pressure insufficient' on the display for about 3 seconds when you start the engine (stop light also shows).

The car is also clattering as well more than it should.

Would you have any idea on what could be wrong?
Should I just change the oil, filter and switch?


Did you check the oil level?
2010 Berlingo Multispace HDi 110 with FAP. Persamos green.

[Image: ab197646.gif]
Yeah, oil level seems fine.
what service history does it have - how many miles has it done - is it smoking or down on power - are the injectors leaking - what is the play like in the turbo bearings?
It has 2 years service history (i.e. when i've had it). not smoking or down on power. done 126k. Just had 1 injector reconditioned and I think 1 more might be a little damp.
Dont know what the turbo is like.
when was the last service done?
how about the power and smoke?
I would be inclined to remove the sump and modify the oil pick up by removing the strainer.

fill with a new filter and oil of the correct spec, go for a short drive eg 10 miles come back and renew the oil and filter.

This is the minimum - you also need to inspect the turbo like i said and i may be wise the modify the turbo oil feed pipe eg remove the filters from the banjo bolts.

It could be the oil pressure switch but i would not take any chances with a 1.6hdi
last service done about 2 months ago. no loss of power and no smoke.

ok thanks for that. I'll get them to remove the sump and remove the strainer.
I can then take it home and back the next day for the same again. It shouldn't be too dirty as it was only serviced 2 months ago.

What oil would you put in it?

Use this or equivalent Total Quartz Ineo ECS 5W30 Engine Oil.

That is your staring point anyway whist the garage have it in get them to do a diag on it to see if any fault codes come up also ask them to check turbo bearings.

If an injector seal is leaking you can hear them chuffing - so get that one you suspect checked.

Hope all goes ok Swarv

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
splayed rear wheels
Last Post:Johny555
Today 10:39 AM
» Replies: 1
» Views: 17
I'm hearing better or smt...
Last Post:Luis Rosa
Today 10:16 AM
» Replies: 8
» Views: 265
Car smell...
Last Post:noidea0
Today 09:59 AM
» Replies: 0
» Views: 18
M49 1.9 diesel misfire a...
Last Post:Jane Rushby
Today 09:57 AM
» Replies: 2
» Views: 67
Is there a need to conver...
Last Post:noidea0
Today 09:41 AM
» Replies: 19
» Views: 919
Heater Matrix replacement...
Last Post:geoff
Today 07:48 AM
» Replies: 24
» Views: 3821
2006 1.6hdi - indicators ...
Last Post:geoff
Today 07:44 AM
» Replies: 14
» Views: 366
Checking how much DPF Add...
Last Post:ntm1275
Yesterday 11:40 PM
» Replies: 3
» Views: 82
Rear reversing sensors
Last Post:tarrymittens
Yesterday 10:01 PM
» Replies: 2
» Views: 128
Blingo Help Please
Last Post:jj9
Yesterday 09:30 PM
» Replies: 12
» Views: 1300

Locations of visitors to this page