Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hi to you All. New guy, just joined a few minutes ago. I have placed an order for a new one ( XTR 115), and now having second thoughts after reading so many having problems with steering issues and uneven tyre wear and related suspension from new. Not owned one before, seemed the right choice at the time. What with all the grand children and everything and falling within budget. I have owned C2 and C3 in the past with no major issues. Has any one had problems with the latest ? Love to hear from you GOOD or BAD.
Welcome along to the crew!
Want Help with the Forum? Read Help Documents Here
 [Image: mybbsig.php]

Welcome to the forum

My 2010 110 XTR has been faultless since I bought it one and half years ago with none of the issues you mention
Thanks for that ntm1275, feel better already
Hello Snooky welcome to the forum just remember you only read a bout the bad one's think of how many other's out there with no problem's so enjoy your new toy  Smile
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy

Hi Snooky
I got a new 2ltr Multispace in 2003 and ran it for 9 years with no problems, I then got my present XTR almost 3 years ago again I have had no problems with it at all. Must confess my mileage is very low as I got the new one to use when visiting our daughter in Edinburgh (I am in Kent)  then she moved back down south! arghh! I have had no steering or tyre problems at all.
As Jed says loads more people complain, and rightly so if they have problems, than those who have one trouble free.

2012 Iron Grey XTR 110 with lots of bits and bobs.

My Berlingo 90bhp from 2009 has don 125.000km now without problems, only normal service, and are very happy about the car, it has only been positiv the hole way.

Lokking forward to some pictures off the car, when you get it.

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Roof bars for VTR?
Last Post:Jed Clampit
Today 09:40 PM
» Replies: 4
» Views: 82
2005 Berlingo - Aussie Ow...
Last Post:martybelfasthdi
Today 07:50 PM
» Replies: 14
» Views: 261
Eco activated but engine ...
Last Post:doofer
Today 07:50 PM
» Replies: 22
» Views: 498
Front camber out of align...
Last Post:Col
Today 06:46 PM
» Replies: 11
» Views: 226
My Berlingo Camper build....
Last Post:knownowt
Today 06:40 PM
» Replies: 5
» Views: 283
P1351 fault code.
Last Post:Boxer
Today 06:28 PM
» Replies: 13
» Views: 765
Upgrading DAB radio recep...
Last Post:Tree
Today 06:26 PM
» Replies: 14
» Views: 2514
Overheating & part number...
Last Post:kevin58
Today 05:55 PM
» Replies: 36
» Views: 17321
Last Post:ron
Today 04:20 PM
» Replies: 4
» Views: 87
Speedo light not working?
Last Post:brodfather11
Today 04:11 PM
» Replies: 1
» Views: 38

Locations of visitors to this page