Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Intro.
#1
Hi to you All. New guy, just joined a few minutes ago. I have placed an order for a new one ( XTR 115), and now having second thoughts after reading so many having problems with steering issues and uneven tyre wear and related suspension from new. Not owned one before, seemed the right choice at the time. What with all the grand children and everything and falling within budget. I have owned C2 and C3 in the past with no major issues. Has any one had problems with the latest ? Love to hear from you GOOD or BAD.
Reply
#2
Welcome along to the crew!
Want Help with the Forum? Read Help Documents Here
 [Image: mybbsig.php]

Reply
#3
Welcome to the forum

My 2010 110 XTR has been faultless since I bought it one and half years ago with none of the issues you mention
Reply
#4
Thanks for that ntm1275, feel better already
Reply
#5
Hello Snooky welcome to the forum just remember you only read a bout the bad one's think of how many other's out there with no problem's so enjoy your new toy  Smile
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
Reply
#6
Hi Snooky
I got a new 2ltr Multispace in 2003 and ran it for 9 years with no problems, I then got my present XTR almost 3 years ago again I have had no problems with it at all. Must confess my mileage is very low as I got the new one to use when visiting our daughter in Edinburgh (I am in Kent)  then she moved back down south! arghh! I have had no steering or tyre problems at all.
As Jed says loads more people complain, and rightly so if they have problems, than those who have one trouble free.
--------------------------------------------------------------

2012 Iron Grey XTR 110 with lots of bits and bobs.
Reply
#7
Hi

My Berlingo 90bhp from 2009 has don 125.000km now without problems, only normal service, and are very happy about the car, it has only been positiv the hole way.

Lokking forward to some pictures off the car, when you get it.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Poor cold startup 1.9
Last Post:Top drive
Today 07:56 AM
» Replies: 31
» Views: 691
Washers not working
Last Post:Redjoe100
Today 07:55 AM
» Replies: 4
» Views: 82
peugeot charger
Last Post:3rensho
Today 06:46 AM
» Replies: 3
» Views: 81
Aftermarket radio stalk C...
Last Post:Matt Haigh
Yesterday 11:53 PM
» Replies: 7
» Views: 251
Reverse light switch prob...
Last Post:willpisme
Yesterday 10:02 PM
» Replies: 4
» Views: 64
Carpet
Last Post:Shaunchippy95
Yesterday 09:50 PM
» Replies: 0
» Views: 33
2-Button Key Upgrade
Last Post:Matt Haigh
Yesterday 09:24 PM
» Replies: 0
» Views: 35
Fuel consumption
Last Post:ron
Yesterday 06:28 PM
» Replies: 9
» Views: 217
Heyup
Last Post:polar
Yesterday 05:03 PM
» Replies: 7
» Views: 311
Amateur radio
Last Post:nicko
Yesterday 04:06 PM
» Replies: 25
» Views: 8288

Locations of visitors to this page