Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Front spring broken
#1
Another problem!
After sorting my flat battery a couple of days ago, I took it for a drive and straightaway noticed a banging noise when turning, coming from the drivers side. It sounded like an 'unsafe' type of noise so I turned back.
I took the wheel off this morning and discovered the front road spring has broken, right at the top end. Great!
Anyway, going to do job myself so picked up a new spring, borrowed some spring compressors and am going to tackle it in the morning.
Can anyone give me any pointers, any special tools needed before I start?
Parts shop also mentioned top bearing might need changing too as they apparently sieze and that can cause spring to break as it can't turn. Is this true?
Thanks.
Reply
#2
http://www.berlingoforum.co.uk/thread-11042.html
Reply
#3
Replace the bearing AND the top mount as a matter of course. Every one of these I've done has had a knackered mount too. It's a pain when you only find out it's still rattling once it's all back together.

Sent from cold, windy place.
2004 Multispace Desire HDi - "Bertie"
Reply
#4
Thanks for replies.
Just looking through old receipts and found that the previous owner had the passenger side spring and top mount replaced Feb 2014, only 4000 miles ago, by Citroen garage so I guess the that side is good for a while anyway.
Reply
#5
Managed to get strut out yesterday. Bit of a chew as the spring had broken at the top and had gone past the top mount and was pushing up into body. I had to compress the spring a fair bit to shorten the total length of strut enough for it to come out, very tight in the end.
Have been reading up on the issues with springs breaking on citroens and peugeots, the recalls and the scary stories where the spring breaks and punctures the tyre. It happened to a friends Scenic, luckily at low speed but didn't realise it was such a common fault. Should these berlingos all have a larger cup fitted to the base now as mine doesn't.
Reply
#6
Well my MK2 2.0hdi 2003 did have the cups fitted by Citroen after a recall, as for 'larger' cups I don't know.
--------------------------------------------------------------

2012 Iron Grey XTR 110 with lots of bits and bobs.
Reply
#7
Managed to fit new spring a few days ago. This was not as easy as I'd anticipated.
Due to the top part of spring ending up curling past the top mount, it wouldn't compress much so had to cut that bit off first with grinder.
With it all apart, I inspected the top bearing and it was in perfect order, looked quite a recent fit so no need for a new one.
New spring was a total pain to compress, with 2 proper spring compressors I expected it to just wind down equally but it just kept distorting and I didn't feel confident safety wise (this was my first spring job). I took it to a friend who is an old timer engineer sort who's done many a spring job and left it with him. It still took him a while to get it fit properly when compressed and we both agreed that where the spring finishes at the top is a cr@p design and looks unsafe.
Anyway, all back on and another job off the list.
Reply
#8
I can only guess that you were using short spring compressors. The springs are quite long, and I have a pair of lo get compressors. It quite literally took me 10 mins to swap the spring over.

Sent from cold, windy place.
2004 Multispace Desire HDi - "Bertie"
Reply
#9
You have a good point there Mike. They were the only ones I could borrow and may have been too short for these springs, it did cross my mind briefly but then I thought, standard springs, standard compressors, this should be easy enough!
I shall know better next time.
Thanks.
Reply
#10
Ah yes, they are a t**t without the right compressors. Like you, I learnt this the hard way the first time I did one on mine (passenger side). It was a nightmare even with an air wrench to wind the compressors down with. I think we ended up using 3 on it in the end.

I bought a long pair after that and even using a normal ratchet it was a piece of cake.

Sent from cold, windy place.
2004 Multispace Desire HDi - "Bertie"
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Ligts won't go off!
Last Post:Berlingos12
Today 02:50 PM
» Replies: 10
» Views: 427
Rear hub nut torque setti...
Last Post:cancunia
Today 01:47 PM
» Replies: 13
» Views: 184
temperatue dial
Last Post:polar
Today 11:47 AM
» Replies: 1
» Views: 25
Loud beeping from radio u...
Last Post:Tree
Today 08:35 AM
» Replies: 2
» Views: 69
DW8 engine tapping
Last Post:brodfather11
Today 08:30 AM
» Replies: 1
» Views: 52
Washers not working
Last Post:Luis Rosa
Today 07:47 AM
» Replies: 8
» Views: 215
increase in a ratchet-typ...
Last Post:saskak
Today 12:36 AM
» Replies: 7
» Views: 145
Rear Wiper Motor
Last Post:madwelshman
Yesterday 10:42 PM
» Replies: 3
» Views: 123
Heater control unit/resis...
Last Post:mreid63
Yesterday 10:34 PM
» Replies: 5
» Views: 348
Facial light replacement
Last Post:Mike
Yesterday 09:23 PM
» Replies: 11
» Views: 306

Locations of visitors to this page