Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
front strut problem
Hi allSmile

I have a litle problem when I assemble the front strut on my 05 berlingo 2.0 Hdi.

I have replaced the shock absorber, spring, top spring mount and bearing due to heavy steering and a broken spring (MOT failures)

My problem is that when releasing the spring clamps, the dustshield rubs into the bearing,  putting on weight  only makes it worse. (absorber isn't staying in the middle of the bearing)

Have anyone experienced this before? and is it normal,  have I assembled anything wrong, or is my top mounts shot?

Thank you


new spring had paintmarks on the opposite side than the old ones and everything lined up much better  when turning the spring upside downSmile
That's good you got it sorted a pain when things like that doesn't go to plan, for future fitting for others did the new spring come with a arrow painted so show what way up it should be fitted?
No, and both ends look quite similar, but with one of the ends curving a little different at one end... They were colourmarked, but that didnt match the old ones...
Nice to see you got it sorted  Smile
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy


Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Tool kit for berlingo ban...
Last Post:Madhouse
Today 12:33 PM
» Replies: 12
» Views: 373
Cruise control possible o...
Last Post:Growler73
Today 12:10 PM
» Replies: 4
» Views: 138
berlingo 2016 xtr corneri...
Last Post:andy-M
Today 10:45 AM
» Replies: 0
» Views: 28
Checking how much DPF Add...
Last Post:ntm1275
Today 10:40 AM
» Replies: 0
» Views: 30
Roadies' Van - an Update.
Last Post:Roadie
Today 10:22 AM
» Replies: 12
» Views: 1989
2006 1.6hdi - indicators ...
Last Post:geoff
Today 08:30 AM
» Replies: 12
» Views: 323
2012 berlingo radio setti...
Last Post:Luis Rosa
Today 07:37 AM
» Replies: 12
» Views: 295
Can anyone recommend a to...
Last Post:nicebiscuit
Today 07:15 AM
» Replies: 3
» Views: 145
Speedo/milometer fault
Last Post:brajomobil
Today 06:11 AM
» Replies: 11
» Views: 939
Rear reversing sensors
Last Post:Luis Rosa
Today 04:35 AM
» Replies: 1
» Views: 86

Locations of visitors to this page