Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Oil cooler problem
The oil cooler has gone on my 1.9d, I was driving it home with the oil cooler gone as I didn't realise it had gone until my car over heated round the corner from my house.

When I got home I thought I'll clean all the oil out my coolant took all the hose's off and cleaned everything including inside the block, I began the progress of putting it back together and fitted a new thermostat to see if I had any other issues. I started the engine up before fitting the a new oil cooler just to see if it still overheated as I didn't want to waste my money on a oil cooler and have more issues. (Seems pointless I know)

The water is now not pumping around and the coolant isn't passing through the hole engine and overheating. Is this down to the oil cooler or could this be a water pump or something else?

Also the heater matrix starting working again after this happened..... Strange

Thanks in adavance.

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
something new
Last Post:Stitches
Today 02:34 PM
» Replies: 0
» Views: 13
Last Post:malgpz900
Today 01:33 PM
» Replies: 1
» Views: 30
Heater Matrix replacement...
Last Post:noworries81
Today 01:13 PM
» Replies: 22
» Views: 3714
Black Smoke
Last Post:old son
Today 10:59 AM
» Replies: 4
» Views: 125
2012 berlingo radio setti...
Last Post:doofer
Today 10:58 AM
» Replies: 11
» Views: 236
New Battery
Last Post:doofer
Today 10:56 AM
» Replies: 5
» Views: 100
Cruise control possible o...
Last Post:brajomobil
Today 10:09 AM
» Replies: 2
» Views: 108
Berlingo VTR to ''XTR'' l...
Today 09:52 AM
» Replies: 6
» Views: 267
Strange exhaust blowing n...
Last Post:ffrenchie
Today 08:53 AM
» Replies: 2
» Views: 70
P1351 fault code.
Last Post:Boxer
Today 07:27 AM
» Replies: 16
» Views: 850

Locations of visitors to this page