Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] From Bad to Worse
#1
I have a berlingo multispace 1.9d timing belt broke unfortunate set of circumstances power steering pump leaked onto auxiliary belt then took out timing belt. Went in to be sorted was there 2 weeks £750 pounds lighter, on a cold start up makes a heck of a noise so asked the garage to have another look. They now say its the hydraulic tappets they can be moved quite easy so they are rattling. Dose my o3 berlingo 1.9d have hydraulic tappets as i thought they had to have shims on them and be adjusted and if they are hydraulic how much are they to get replaced.
Many thanks in advance
Reply
#2
You're right,shims,not hydraulic.I would be very suspicious of their motives.
Strawberry flavoured windows  Dodgy
Reply
#3
Thanks Ron for the reply. Thought I was loosing my mind, read the Haynes manual and it says 1.6 hydraulic 1.9 shims not sure what they are up to.
Thanks.
Reply
#4
Hi could anyone put me onto a reputable diesel specialists here in Lancashire near Rossendale as I am starting to loose confidence in my local garage. Many thanks
Reply
#5
Update on our berlingo garage now says the tappets are shims as Ron said you can press then down quite easy with screw driver. But know one knows why it is rattiling on the top end I thought it was a lack of oil to the head. But they say the oil is OK. Seen it today with cover off showing me the tappets did notice that two of the ports on the manifold were very wet like oil the others dry like soot has anyone got any ideas as the garage are lost and I am £750 poorer.
Many thanks
Reply
#6
Have they got the fuel injection timing correct.  If it is wrong its makes a really worrying noise as if the big ends are gone.

I would be querying why the ports (inlet ?) are wet , it may be the valves are letting the fuel/ air mixture back out when under pressure. As if the valves are not seating properly or fuel injecting before valves properly closed.?

Its a pity you paid them before trying it out.  If I gave them £750 for repairs  I would expect them to know how to repair it. Dodgy
Reply
#7
Hi update on my berlingo its sorted. The garage said it was the cam shaft pulley that was rattling been using the car for a few days and up to now all is well I think.

Thanks for your help and advice.
Reply
#8
that means they didn't torque it properly the first time ?
chance nothing happened for the same the belt was gone again .
Reply
#9
Nice to see you got it sorted a worrying time for you happy day's a gain  Smile
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
2012 enterprise berlingo ...
Last Post:Johny555
Today 05:37 PM
» Replies: 9
» Views: 175
2.0 HDi fuel issues as pe...
Last Post:G.mk3
Today 05:28 PM
» Replies: 2
» Views: 17
citroen berlingo desire 1...
Last Post:Jed Clampit
Today 05:22 PM
» Replies: 4
» Views: 91
12v for lighter front
Last Post:ghost123uk
Today 02:59 PM
» Replies: 6
» Views: 143
Insurance!
Last Post:Col
Today 02:57 PM
» Replies: 9
» Views: 879
"Ultimate" type Diesel fu...
Last Post:ghost123uk
Today 02:48 PM
» Replies: 17
» Views: 407
2025 Diesel Ban
Last Post:rnamman
Today 01:58 PM
» Replies: 9
» Views: 143
Alloys
Last Post:Rich Walker
Today 01:36 PM
» Replies: 3
» Views: 120
1.6 16v petrol cambelt
Last Post:sks01773
Today 09:28 AM
» Replies: 4
» Views: 78
Berlingo won't start 2009...
Last Post:brodfather11
Today 06:20 AM
» Replies: 8
» Views: 214

Locations of visitors to this page