Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
heater hose seal needs replacing
#1
Sad 
Hi I have a 1998 1.8 diesel Berlingo Van with a leaking heater hose seal. tried looking all over the net but unable to find a replacement one. any ideas?
I have tried sealing with K-Seal (which worked for a couple of days), cant seal with hose tape as it wont stop leaking.
Any and all ideas i am willing to try. lol
Reply
#2
Hi,
Can't the main dealer help you?
Griff
Landmark
Ex 1.4 Berlingo Multispace
Reply
#3
(19-03-2015, 04:10 PM)Jane Oliver Wrote:  Hi I have a 1998 1.8 diesel Berlingo Van with a leaking heater hose seal. tried looking all over the net but unable to find a replacement one. any ideas?
I have tried sealing with K-Seal (which worked for a couple of days), cant seal with hose tape as it wont stop leaking.
Any and all ideas i am willing to try. lol

Is this the plug-in double connector on the firewall? Had one of those blow off on a Xantia some years back, certainly made heads turn as it filled the street with steam! Supposed to seal with O-rings, but IME they are not reliable once it gets old.

If so, slacken the mounting plate and run a couple of strong cable ties or (better) copper wire behind it, then refit it. Degrease and dry the assembly thoroughly and coat both surfaces with a decent quality plumber's silicone. Put in and make secure with ties or copper wire. Leave overnight before refilling, then warm up and top up with radiator cap left off (so no pressure) until fully warm. Bear in mind that extraction may be difficult afterwards.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Running on chip oil
Last Post:cancunia
Today 09:51 AM
» Replies: 4
» Views: 62
2004 Berlino Aerial
Last Post:malgpz900
Today 09:37 AM
» Replies: 3
» Views: 56
2005 2.0 HDI Siemens pump...
Last Post:cancunia
Today 09:05 AM
» Replies: 1
» Views: 54
1.6 hdi 90bhp Turbo and i...
Last Post:peteh80
Today 06:58 AM
» Replies: 4
» Views: 232
Poor cold startup 1.9
Last Post:Top drive
Today 12:24 AM
» Replies: 40
» Views: 1107
Washers not working
Last Post:Lighty
Yesterday 09:09 PM
» Replies: 11
» Views: 321
Reverse light switch prob...
Last Post:Col
Yesterday 07:22 PM
» Replies: 12
» Views: 285
Fuse is burning all the t...
Last Post:fernandoblas
Yesterday 05:23 PM
» Replies: 12
» Views: 423
HELP! Smashed passenger w...
Last Post:Sootyfoot
Yesterday 04:31 PM
» Replies: 2
» Views: 89
Diagnostic "gear" / Softw...
Last Post:cancunia
Yesterday 04:19 PM
» Replies: 15
» Views: 631

Locations of visitors to this page