Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hi Guys, wondering if you could help me,

I have a Mk1 1.9d berlingo. I turned the engine on the other day and the battery light stayed on with the engine running, everything worked fine at this time driving at night with full beam lights on and radio.

I started the van maybe 5 times, that evening after checking the wires to the alternator (Theres only two?) but the light remained on when the engine is running.

Since then I have used the van multiple times and hasn't failed to start yet, but there is no power to the radio and full beam lights wont stay on? I started the van over 6 times today with a friend trying to determine the source of the problem.

Does anyone have any ideas as to what could be wrong and how to fix?
Hi cookie
First of all to rule out the alternator get a meter on it and check the output, should be about 14.5 v.
there is an engine running relay that can play up if the earth connection is faulty. Its mounted on the inner n/s wing
Hi Brodfather

Thanks for the quick reply.

I have never been great with electrics, am I testing the two connections points on top of the alternator for 14.5v?
With the engine running and lights on test the voltage at the battery, if your alternator is OK it should be 14.5 volts. With the engine stopped it will be about 12.5 or so .
The large wire from the alternator supplies the battery , it is the output from the alternator , the smaller wire is the feed that makes the alternator work. it should have 12 volts at it with ignition on.

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Lexia Mods Please..
Last Post:Trevor
Today 06:16 PM
» Replies: 1
» Views: 28
Front camber out of align...
Last Post:Civvic
Today 05:39 PM
» Replies: 0
» Views: 11
Electrical Fault
Last Post:Civvic
Today 05:11 PM
» Replies: 1
» Views: 55
Last Post:polar
Today 04:44 PM
» Replies: 2
» Views: 46
Still on the elusive 4x10...
Last Post:Carl Davis Hulin
Today 04:41 PM
» Replies: 0
» Views: 29
Diesel fan in Petrol engi...
Last Post:Johny555
Today 10:34 AM
» Replies: 1
» Views: 43
Wanted Berlingo / Partner...
Last Post:b-f-c
Today 08:32 AM
» Replies: 0
» Views: 56
Eco activated but engine ...
Last Post:brajomobil
Today 08:10 AM
» Replies: 13
» Views: 335
WTB Rear Hatch in Silver,...
Last Post:Def-fid
Today 07:56 AM
» Replies: 0
» Views: 33
font fog light bulb chang...
Last Post:Luis Rosa
Today 05:31 AM
» Replies: 2
» Views: 71

Locations of visitors to this page