Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Mystery Connector - 1.4 Berlingo
I've been poking around under the bonnet, and happened across this connector.  Does anyone know what it's for?

 I can't find anywhere for it to plug in to, and it's not long enough to reach very far.  Everything seems to be working, although it idles poorly - just wondered if I needed it?

 Many thanks,

[Image: Connector%202_zpsjzmfuydl.jpg]
[Image: Connector%201_zpstdoacrgz.jpg]
I think it's a low level brake fluid warning switch wiring not used on your speck model
You need to clean those leave's from the bottom of you wind screen or you will get water ingress in to the electric's
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy

[+] 1 user says Thank You to Jed Clampit for this post
Do you have a tree growing in your engine bay?
Thanks Jed - and I will get cleaning

Jonnie - there's all sorts of things growing in this van. It gets thoroughly abused. I expect that the Natural History Museum will want to take a look one day!
Is that not the brake fluid sensor/wiring attached to the master cylinder in the first picture ???? I have the same redundant connector in my 2008 1.4.Take the scuttle off and unblock the drain holes that run down to the bottom off each wing by the A pillar, and its worth poking all the crap out that will have built up there to.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
My Berlingo Camper build....
Last Post:Sootyfoot
Today 05:11 AM
» Replies: 6
» Views: 291
Roof bars for VTR?
Last Post:Jed Clampit
Yesterday 09:40 PM
» Replies: 4
» Views: 86
2005 Berlingo - Aussie Ow...
Last Post:martybelfasthdi
Yesterday 07:50 PM
» Replies: 14
» Views: 263
Eco activated but engine ...
Last Post:doofer
Yesterday 07:50 PM
» Replies: 22
» Views: 504
Front camber out of align...
Last Post:Col
Yesterday 06:46 PM
» Replies: 11
» Views: 240
P1351 fault code.
Last Post:Boxer
Yesterday 06:28 PM
» Replies: 13
» Views: 775
Upgrading DAB radio recep...
Last Post:Tree
Yesterday 06:26 PM
» Replies: 14
» Views: 2522
Overheating & part number...
Last Post:kevin58
Yesterday 05:55 PM
» Replies: 36
» Views: 17326
Last Post:ron
Yesterday 04:20 PM
» Replies: 4
» Views: 90
Speedo light not working?
Last Post:brodfather11
Yesterday 04:11 PM
» Replies: 1
» Views: 45

Locations of visitors to this page