Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
XTR90: Rattle after front coil springs changed
#1
The OSF coil spring on my 2008 XTR snapped about an inch from the top, so I had both front springs replaced by a local independent garage a couple of weeks ago. On collecting the vehicle I noticed an intermittent rattling noise ( sound clip here ) but wasn't able to take it back to the garage until last Friday so they could have a look.

They had the vehicle all Friday and Saturday but weren't able to find where the noise is coming from, so have asked if I can take it back this Friday so they can replace the springs again with a set from a different manufacturer to see if that solves the problem. The fitter who did the job thinks the noise must now be from the springs, but the manager thinks the noise is coming from behind the dash.

I decided to have a look myself yesterday and am hoping that I've identified the problem - I just wanted to check my theory first before going back to the garage.

The fitter mentioned that he'd removed the plastic trim over the wiper motor (the full width one between the top of the bonnet and windscreen), to get access to the top of the struts. This seamed a bit loose in the middle and could be pushed against the bulkhead/windscreen. It also didn't line up perfectly with the wiper output shaft (see below)  

[Image: 20150504_berlingo1.jpg]

Looking at the photo below, it appears to me that there is fitting missing in the centre top of the air vent. Presumably the purpose of which is to secure the centre of this plastic trim.  

[Image: 20150504_berlingo2.jpg]

The following 2 photo show where I assume this fitting connects with the bulkhead.

[Image: 20150504_berlingo3.jpg]

[Image: 20150504_berlingo4.jpg]

Can anyone confirm that they has some type of securing fitting in this position on their vehicle (a photo would be brilliant). I've tried to find an online exploded parts diagram without success.

Thanks.

Colin
Reply
#2
HI. look's like the scuttle has been fitted back with bits missing......that's a drain hole at the back.......but the there is a star screw missing in the scuttle............plus things under scuttle things might not be tight as well........bits missing ........sorry no picture.......but got same model......take it back............[Image: rolleyes.png]............plus the air filter could be loose.....got same noise,doing air filter mod later when weather changes.
Reply
#3
I think you could be right gazahull, I found this diagram on the service.citroen.com website after putting in my VIN number

[Image: 20150504_berlingo5.jpg]
Part 18, which is listed as "8251 EE  Wing grille air inlet scoop", appears to have a bar down the centre which I assume the star screw you mention screws into to lock down the scuttle.

The garage did have a theory that the noise could have been the air filter and asked if the car had recently been serviced, but the last service was 12 months ago. What is the air filter mod you mentioned?

Colin
Reply
#4
Did they replace the strut top mount and bearing? If not, I'd bet that is the issue. They might appear to look ok but invariably something happens to them when the spring is damaged. My Citroen dealer told me tales of woe about these and C4s which rattle like hell if the top mounts aren't replaced too.

Sent from my SM-N9005 using Tapatalk
2004 Multispace Desire HDi - "Bertie"
Reply
#5
yer. just replacing air filter and putting an after market one in . with my own modifications. should stop the dam rattle, plus saves time replacing the stupid filter. .......try putting your hands under scuttle where your air filter box is [back of engine] and firmly press down, maybe just need pushing back in mounts, the dreaded filter box rattle.            cheers
Reply
#6
There is a peace of bracket missing form under the scuttle tray that the centre screw fit's too see if they have miss laid it  Sad  Dodgy
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
Reply
#7
(05-05-2015, 08:46 PM)Jed Clampit Wrote:  There is a peace of bracket missing form under the scuttle tray that the centre screw fit's too see if they have miss laid it  Sad  Dodgy

Hi Jed. Yes I've just had another look and can see that the bracket in the centre of the air inlet scoop is missing. Hopefully this is a separate part which has been misplaced, rather than part of the main moulding which has been snapped off then the evidence hidden.

Colin
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Berlingo won't start 2009...
Last Post:Chri5
Today 12:22 AM
» Replies: 7
» Views: 170
Insurance!
Last Post:fcamp
Yesterday 10:52 PM
» Replies: 6
» Views: 825
citroen berlingo desire 1...
Last Post:sks01773
Yesterday 10:47 PM
» Replies: 2
» Views: 40
1.6 16v petrol cambelt
Last Post:sks01773
Yesterday 10:40 PM
» Replies: 0
» Views: 20
B9 DPF Tank Top-Up
Last Post:Lighty
Yesterday 10:06 PM
» Replies: 5
» Views: 113
Rear light Cluster
Last Post:Peter Guy
Yesterday 09:57 PM
» Replies: 2
» Views: 31
2012 enterprise berlingo ...
Last Post:CourierJim
Yesterday 09:03 PM
» Replies: 6
» Views: 119
Head gasket failure.
Last Post:Civvic
Yesterday 08:08 PM
» Replies: 13
» Views: 361
At last
Last Post:Gerald Bostock
Yesterday 08:06 PM
» Replies: 9
» Views: 330
Conversion from manual to...
Last Post:Civvic
Yesterday 07:58 PM
» Replies: 1
» Views: 89

Locations of visitors to this page