Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Help for George Hall!!
OK! George has posted in various other threads about a problem with his '06 2.0Hdi.

He doesn't know how to start a new thread so I have started one for him!'s your thread mate. Tell us what's wrong and someone will hopefully be able to offer you some advice Cool
[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]
Thanks very much the problem Iam having at the moment wot happernd is my power streering belt snapped on my way from work in the van I heard sum thing so I pulled up got out and poped bonnet I seen the belt on floor but van wos still running so a got back in and drove it home on battery how ever it cut out as pulled in my street so next day gotit towed to garage by a friend of myn we're I had new belt new starter motor and new battery put on the must of had faults befor belt snapped but still drove fine as used it every day to go to work in sum yellow cum on about engine management but quick turn off then back it whent out but since this happerd the vans never stared since any ideas thank you

Sent from my iPhone using Tapatalk
Why did the garage put a new starter and battery on when it was just the power steering belt that had snapped?
What may have happened, is that some of the belt went into the cover, and didn't initially make the cam belt jump, but may have subsequently picked up, and caused this issue.
If your garage guy is any good, he can view live data on a diagnostic tool and look for cam & crank synchronisation on cranking. Personally I would always take the cover off if a belt broke, as this tends to happen a lot, especially if the belt shredded into strips.

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Poor fuel economy.. again...
Last Post:Jane Rushby
Today 06:50 PM
» Replies: 13
» Views: 1382
Where Did you find
Last Post:Jane Rushby
Today 06:26 PM
» Replies: 93
» Views: 165483
Radio needs VIN programme
Last Post:Tomcat3
Today 06:09 PM
» Replies: 3
» Views: 132
Last Post:Jane Rushby
Today 05:18 PM
» Replies: 5
» Views: 129
Speedo/milometer fault
Last Post:Gixxerguyk8
Today 04:51 PM
» Replies: 10
» Views: 894
Rear reversing sensors
Last Post:tarrymittens
Today 03:55 PM
» Replies: 0
» Views: 24
something new
Last Post:Stitches
Today 02:34 PM
» Replies: 0
» Views: 31
Last Post:malgpz900
Today 01:33 PM
» Replies: 1
» Views: 40
Heater Matrix replacement...
Last Post:noworries81
Today 01:13 PM
» Replies: 22
» Views: 3730
Black Smoke
Last Post:old son
Today 10:59 AM
» Replies: 4
» Views: 133

Locations of visitors to this page