Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Warning Light] Management shuts down the turbo
#1
Hi Guys, thanks in advance for your help with this one...

I have a 1.6hdi Berlingo 2007 with an intermittent fault. Sometimes when accelerating hard, or motorway driving and pushing over 70mph, the Engine Management System shuts the turbo off, and the engine light comes on. The way to turn it back on is to turn the engine off and on again, the turbo comes back to use no problem.

We can't seem to figure out what is causing this, and here's what we've done to investigate so far...

- The turbo has been checked and found no fault
- The waste gate has been checked and found to be freely moving, no fault
- We ran a turbo cleaner through to clean up sensors etc
- The Manifold absolute pressure sensor has been replaced (the engine light hasn't been cleared after this, does that matter??)
- We found a hole in the boost pipe, this has been replaced.

Please help me with some insight into this problem!!
Reply
#2
(18-06-2015, 10:09 AM)Rothers1 Wrote:  Hi Guys, thanks in advance for your help with this one...

I have a 1.6hdi Berlingo 2007 with an intermittent fault. Sometimes when accelerating hard, or motorway driving and pushing over 70mph, the Engine Management System shuts the turbo off, and the engine light comes on. The way to turn it back on is to turn the engine off and on again, the turbo comes back to use no problem.


After you turn the engine off and then on again , MIL light clears ?

Do you have Lexia diagnostic ? 
Reply
#3
(18-06-2015, 11:10 AM)brajomobil Wrote:  
(18-06-2015, 10:09 AM)Rothers1 Wrote:  Hi Guys, thanks in advance for your help with this one...

I have a 1.6hdi Berlingo 2007 with an intermittent fault. Sometimes when accelerating hard, or motorway driving and pushing over 70mph, the Engine Management System shuts the turbo off, and the engine light comes on. The way to turn it back on is to turn the engine off and on again, the turbo comes back to use no problem.


After you turn the engine off and then on again , MIL light clears ?

Do you have Lexia diagnostic ? 

Thanks for your reply! No, the light stays on. I've asked my guy to come and run diagnostics on the van today so I've got some codes to work with. I dont have Lexia Diagnostic no Sad
Reply
#4
This is because the turbo pressure is getting too high so the ECU shuts it off to prevent damage.

Try fitting a new turbo electro valve, and also check for boost leaks. Sometimes if you have a boost leak it can stuggle to keep up with the pressure and then over compensate and make too much pressure.

Also a bad remap can cause it to overboost, has it been mapped at all?
http://www.hdi-tuning.co.uk
Remaps available for 1.6 EDC16, 2.0 Bosch EDC15 & Siemens SID801
Reply
#5
(18-06-2015, 03:37 PM)pro_steve Wrote:  This is because the turbo pressure is getting too high so the ECU shuts it off to prevent damage.

Try fitting a new turbo electro valve, and also check for boost leaks. Sometimes if you have a boost leak it can stuggle to keep up with the pressure and then over compensate and make too much pressure.

Also a bad remap can cause it to overboost, has it been mapped at all?

Thanks! I'll give that a go and see how I get on. We found a leak in the boost pipe, but it's been replaced and it's still there! Never been mapped either. Thanks again.
Reply
#6
(18-06-2015, 07:55 PM)Rothers1 Wrote:  
(18-06-2015, 03:37 PM)pro_steve Wrote:  This is because the turbo pressure is getting too high so the ECU shuts it off to prevent damage.

Try fitting a new turbo electro valve, and also check for boost leaks. Sometimes if you have a boost leak it can stuggle to keep up with the pressure and then over compensate and make too much pressure.

Also a bad remap can cause it to overboost, has it been mapped at all?

Thanks! I'll give that a go and see how I get on. We found a leak in the boost pipe, but it's been replaced and it's still there! Never been mapped either. Thanks again.
pro_steve I'm trying to find the correct part but to be honest I'm not that savvy with finding new parts. Could you point me towards the correct Electrovalve please?? Thanks again!
Reply
#7
should be bolted on the back of the engine near the left side, it's orangey brown in colour.
http://www.hdi-tuning.co.uk
Remaps available for 1.6 EDC16, 2.0 Bosch EDC15 & Siemens SID801
Reply
#8
(18-06-2015, 07:55 PM)Rothers1 Wrote:  
(18-06-2015, 03:37 PM)pro_steve Wrote:  This is because the turbo pressure is getting too high so the ECU shuts it off to prevent damage.

Try fitting a new turbo electro valve, and also check for boost leaks. Sometimes if you have a boost leak it can stuggle to keep up with the pressure and then over compensate and make too much pressure.
Thanks! I'll give that a go and see how I get on. We found a leak in the boost pipe, but it's been replaced and it's still there! Never been mapped either. Thanks again.

Lexia will tell you if MIL is from low or high pressure. Not sure if some the aftermarket diagnostic will help. Also check what pro_steve suggested.

Best regards,
brajomobil
Reply
#9
(19-06-2015, 07:33 AM)pro_steve Wrote:  should be bolted on the back of the engine near the left side, it's orangey brown in colour.
Is the Turno Electro Valve also called a Vacuum Solenoid Valve? I can't find a turbo electro valve anywhere!
Reply
#10
Thanks everyone, I got a Breakers part of ebay for £19, the local mechanic lad fitted it for £20, solved the problem!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
how many miles on yours ?
Last Post:Wyvern
Today 10:27 AM
» Replies: 18
» Views: 808
Roof noise
Last Post:Opensauce
Today 09:59 AM
» Replies: 2
» Views: 67
Rear light Cluster
Last Post:Opensauce
Today 09:50 AM
» Replies: 3
» Views: 87
12v for lighter front
Last Post:ffrenchie
Today 09:49 AM
» Replies: 14
» Views: 319
Saying Hello
Last Post:ghost123uk
Today 09:07 AM
» Replies: 2
» Views: 46
lubricating door
Last Post:brajomobil
Today 08:05 AM
» Replies: 2
» Views: 87
Lexia clone that works wi...
Last Post:brajomobil
Today 08:02 AM
» Replies: 59
» Views: 1862
Heated wing mirrors
Last Post:3rensho
Today 04:30 AM
» Replies: 4
» Views: 127
1.6 16v petrol cambelt
Last Post:cancunia
Yesterday 11:59 PM
» Replies: 13
» Views: 312
Ncb help
Last Post:Jed Clampit
Yesterday 10:32 PM
» Replies: 5
» Views: 162

Locations of visitors to this page