Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Light coming on on it's own whilst driving or parked...
#1
hi guys,

I need some advise, just yesterday my berlingo 2-0 hdi started to swicth the main light on it's own, sometimes when we drive or when parked...whilst driving , the indicator doesn't seem to work unless you correctly switch the light on ( by turning it..)

When we switch the car off, take the key out of the ignition they just seem to "turn" themselves on and when you open the door the alarm to let you know that you have left your light on start beeping and yet the light are not on...you then need to "play" a little bit with the switch for it to stop....

I hope my explanation/ description of the problem makes sense!!!!

Any ideas on what could cause this? I am afraid to come one day to find the battery flat although when the key is not in the ignition i don't think it actually turn the light on...

Thanks for looking.

Franck
Reply
#2
More confused now than when I first read this......
Berlingo Multispace 2.0HDI '54 reg Mediterranean Blue
Reply
#3
Before it started playing up had you done anything to the electrics ie disconnected battery or fitted/changed something?????????
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply
#4
(25-06-2015, 08:59 PM)Tomcat3 Wrote:  Before it started playing up had you done anything to the electrics ie disconnected battery or fitted/changed something?????????

no nothing at all
Reply
#5
(25-06-2015, 08:45 PM)andy-womble Wrote:  More confused now than when I first read this......

Hi andy..

basically the light come on without touching anything..so probably a bad connection...
Reply
#6
I think the light switch it self is worn you could need a new switch
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
Reply
#7
(25-06-2015, 09:18 PM)Jed Clampit Wrote:  I think the light switch it self is worn you could need a new switch

hi,

is this an expensive part and is it easy to change?

thanks
Reply
#8
Comm 2000 unit or failing battery would be my guess.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Heated wing mirrors
Last Post:3rensho
Today 06:00 AM
» Replies: 1
» Views: 24
1.6 hdi 90bhp Turbo and i...
Last Post:Floydster
Yesterday 11:07 PM
» Replies: 1
» Views: 82
how many miles on yours ?
Last Post:Silverberlingo
Yesterday 10:59 PM
» Replies: 17
» Views: 770
1.6 16v petrol cambelt
Last Post:geoff
Yesterday 10:24 PM
» Replies: 5
» Views: 116
Door locking but unlocked
Last Post:DanielEZY0252
Yesterday 09:45 PM
» Replies: 0
» Views: 15
12v for lighter front
Last Post:Jed Clampit
Yesterday 09:07 PM
» Replies: 8
» Views: 188
2.0 HDi fuel issues as pe...
Last Post:G.mk3
Yesterday 07:17 PM
» Replies: 5
» Views: 72
zx1 extralube
Last Post:sks01773
Yesterday 06:07 PM
» Replies: 0
» Views: 48
citroen berlingo desire 1...
Last Post:sks01773
Yesterday 05:57 PM
» Replies: 5
» Views: 138
2012 enterprise berlingo ...
Last Post:Johny555
Yesterday 05:37 PM
» Replies: 9
» Views: 211

Locations of visitors to this page