Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
2.0 HDi expansion tank questions, advice plz
#1
Hi Again guys,

Ive already posted an issue regarding a pressurised expansion tank in another thread. I wasnt sure how to update my last post to make sure people can notice.
Summary is,

2.0 Hdi engine 05 plate. Mileage 87183 miles
1. expansion tank is pressurising with cap on and eventually spits coolant everywhere. radiator pipes expand tight withing a minute. engine doesnt over heat and heater workes fine although a little slow. Just the coolant warning light when enough has been spat out. if i leave cap off and place hand over hole you can feel the pressure, you can see a a light smoke rising out of the tank. ive smelt the smoke and it smells more like hot oil rather than exhaust fumes.

2. Ive swapped caps.
3. done flushes and checked pipes and primed with new coolant to avoid air locks.
4. changed thermostat twice.
5. done a sniffer test which does NOT turn yellow. ( tested fluid via exhaust pipe and it does turn a greeny yellow ).
6. no mayo in oil cap.
7. no oil in expansion tank. Just a slight film on the sides in the top half of the tank.
8. oil via dip stick check looks fine.
9. I ve done a flush isolating the oil cooler and water flows freely.
10. a garage mech insists its the head gasket or worse. He says the ammount of pressure being created, even for a head gasket failure isnt normal. so much so that when turning the engine over it should struggle to start due to amount of pressure loss through the gasket. But the engine starts first time, every time without issue. So he cant figure out why so much pressure is being generated. (hes lost me on that one). His advice was to get rid instead of fixing as it could be opeing up a can of worms plus to the fact that he thinks the injector fixing are seized. thus costing a small fortune.

This advice I want to take, but Ive read on a few other forums over the net that a faulty EGR can cause the excessive pressure. I put this to the mech but he dismissed it saying the exhaust system has nothing to do with the coolant. So why are people on these other forums suggesting such a thing, with some owners opting to blank the EGR which sometimes fixes the pressurising issue.
So Im asking anyone on here with good knowledge and experience with the 2.0HDi engines for advice regarding this matter. Could it be the EGR?, or a faulty oil cooler? or both?
or is it just plain and simply a shafted HG or cracked head.
Ive seriously considered getting rid of by berlingo to replace with a working one, but im struggling to find any for sale at a reasonable price with a decenty mileage. They all seem to be the new gen models at sillly prices or the 1.6 petrol models that have daft road tax costs, or older models with obscene mileage.

all help appreciated guys, sorry again for a repeat thread but im a bit pants with these forums
Reply
#2
Please, check rotation of a impeller of a water pump. If it's ok check and replace gasket.
Such phenomenon appears when the overpressure is in a cooling system.
It can caused by low performance of water pump or breakthrough of exhaust gas.
Reply
#3
The EGR does have a water cooling manifold on the 2.0hdi so it is possible it could be pressurising there. However i have never heard of this happening.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Ncb help
Last Post:Silverberlingo
Today 10:26 PM
» Replies: 4
» Views: 138
Saying Hello
Last Post:Jed Clampit
Today 10:25 PM
» Replies: 1
» Views: 19
1.6 hdi 90bhp Turbo and i...
Last Post:Floydster
Today 07:48 PM
» Replies: 3
» Views: 135
1.6 16v petrol cambelt
Last Post:sks01773
Today 07:37 PM
» Replies: 12
» Views: 250
Heated wing mirrors
Last Post:Trevor
Today 07:06 PM
» Replies: 3
» Views: 82
2025 Diesel Ban
Last Post:Tree
Today 06:17 PM
» Replies: 15
» Views: 345
Hello
Last Post:Johny555
Today 06:04 PM
» Replies: 1
» Views: 19
Roof noise
Last Post:Veitcast
Today 05:48 PM
» Replies: 0
» Views: 28
Fuel consumption
Last Post:Opensauce
Today 05:37 PM
» Replies: 3
» Views: 53
Lexia clone that works wi...
Last Post:kennard
Today 02:59 PM
» Replies: 58
» Views: 1840

Locations of visitors to this page