Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Stereo connection woes
#1
Hi all
As the title suggests I am having a few problems with the stereo in my 2006 van.

I only bought the van a week ago and the current sony stereo doesn't work, I have a brand new Pioneer head unit and apparently correct connector cable but when it is installed i get no sound apart from a squeak when the head unit is turned on.

When looking at the speaker connector block the cables look completely different and none of the cables match, has anyone got any suggestions?

Many thanks

           
Reply
#2
I have tried looking at the haynes manual but it just give numbers for the speaker wires and none of them match up with the ones behind the dash. Does anyone know what the colours on the speaker side connector might relate to?
Reply
#3
Just an update as this might help someone in the future. I found this on the citroen website…..


.pdf   96_berlingofirst-dad-ed01-2008.pdf (Size: 146.58 KB / Downloads: 11)

Managed to find out that by disconnecting some pins that there is a short on the front right hand speaker channel. Now the stereo is working perfectly bar the right hand speaker, but that is a job for another day!  Big Grin
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
2025 Diesel Ban
Last Post:doofer
Today 10:48 AM
» Replies: 12
» Views: 245
12v for lighter front
Last Post:cancunia
Today 10:42 AM
» Replies: 11
» Views: 236
Door locking but unlocked
Last Post:ffrenchie
Today 10:17 AM
» Replies: 3
» Views: 56
Rear seats
Last Post:doofer
Today 09:55 AM
» Replies: 1
» Views: 73
1.6 hdi 90bhp Turbo and i...
Last Post:Trevor
Today 09:46 AM
» Replies: 2
» Views: 101
lubricating door
Last Post:sks01773
Today 08:57 AM
» Replies: 0
» Views: 31
Heated wing mirrors
Last Post:3rensho
Today 06:00 AM
» Replies: 1
» Views: 47
how many miles on yours ?
Last Post:Silverberlingo
Yesterday 10:59 PM
» Replies: 17
» Views: 784
1.6 16v petrol cambelt
Last Post:geoff
Yesterday 10:24 PM
» Replies: 5
» Views: 141
2.0 HDi fuel issues as pe...
Last Post:G.mk3
Yesterday 07:17 PM
» Replies: 5
» Views: 81

Locations of visitors to this page