Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ABS System Fault in mfd
Have an abs fault in my display with a few weeks,mechanic told me it's a control unit which is about €600!,any one ever have this issue?

Sent from my iPhone using Tapatalk
have you had the fault code properly checked, theres a few things it could be
[Image: 2dedca76-4da1-4bd2-aea1-452ddda68256.jpg]
Must ask my technician what the code was and I'll post

Sent from my iPhone using Tapatalk
Got to agree with getting code checked. I was told that I possibly had a control unit failure, but problem turned out to be a faulty connector between wiring harness and the front abs sensor. I then had further problems but some were my own making from making/breaking connections during fault finding, and stuffing my multimeter into connectors, thus damaging contacts.
A good auto electrician with access to code reader might be your best bet. You should be able to find my posts

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Overheating & part number...
Last Post:kevin58
Today 05:55 PM
» Replies: 36
» Views: 17289
Front camber out of align...
Last Post:Civvic
Today 04:39 PM
» Replies: 10
» Views: 186
Last Post:ron
Today 04:20 PM
» Replies: 4
» Views: 72
Speedo light not working?
Last Post:brodfather11
Today 04:11 PM
» Replies: 1
» Views: 27
Lexia Scanner?
Last Post:cancunia
Today 02:30 PM
» Replies: 0
» Views: 27
Eco activated but engine ...
Last Post:doofer
Today 02:28 PM
» Replies: 20
» Views: 473
1.9 dw8 to b 1.8 xud engi...
Last Post:Angusyoung1
Today 01:46 PM
» Replies: 0
» Views: 22
Brand new alloys and tyre...
Last Post:Wadling09
Today 11:13 AM
» Replies: 0
» Views: 48
My Berlingo Camper build....
Last Post:Madhouse
Today 09:14 AM
» Replies: 4
» Views: 259
M49 Budget DIY Camper con...
Last Post:knownowt
Today 08:49 AM
» Replies: 22
» Views: 2349

Locations of visitors to this page