Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
New owner
#1
Hi

New owner of a 56reg MkII, multispace 1.6 diesel. Replaced my old Berlingo van (Costs less on the ferry), great car!

Have just tried to sort out the lights in the clock assembly as they are not working, put new bulbs in but still no lights. Any ideas?
Reply
#2
Hi & welcome.Have you checked fuses? If OK check you have a feed on the connector to the lights(with lights on).
Strawberry flavoured windows  Dodgy
Reply
#3
Hi DavidW, I know of at least one other on here and myself, who have had top clock display problems with 56 reg Berlingos. Mine smouldered and nearly caught fire lol! I seem to remember having to buy a new LCD display unit, might have been up to £80 in cost. Citroen must have bought a really cheap batch of these units from China in 2006!
Reply
#4
Hi

Thanks for reply, have been away so have not had time to look yet. Did foolishly buy a copy of Haynes manual, they seem to  miss  out the display unit.

DavidW
Reply
#5
(30-07-2015, 09:10 PM)ron Wrote:  Hi & welcome.Have you checked fuses? If OK check you have a feed on the connector to the lights(with lights on).

Hello

Will have a look at fuses, which is the fuse that covers the lights on the display?

I only had one light working, so took out the unit to replace the other two bulbs and all then would not work. It could be a fuse although have not found anything else not working yet.

DavidW
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Door locking but unlocked
Last Post:ricc
Today 02:25 PM
» Replies: 4
» Views: 84
"Ultimate" type Diesel fu...
Last Post:ricc
Today 01:56 PM
» Replies: 18
» Views: 467
Heated wing mirrors
Last Post:Tree
Today 01:43 PM
» Replies: 5
» Views: 143
Ncb help
Last Post:ricc
Today 01:34 PM
» Replies: 6
» Views: 170
12v for lighter front
Last Post:ghost123uk
Today 01:07 PM
» Replies: 17
» Views: 351
Poor cold starting. Whats...
Last Post:Kez
Today 12:35 PM
» Replies: 0
» Views: 19
Repair a manual winder wi...
Last Post:AbneyTeal
Today 12:25 PM
» Replies: 0
» Views: 15
Fuel consumption
Last Post:Wyvern
Today 11:18 AM
» Replies: 6
» Views: 106
1.6 16v petrol cambelt
Last Post:sks01773
Today 10:56 AM
» Replies: 14
» Views: 327
lubricating door
Last Post:sks01773
Today 10:52 AM
» Replies: 3
» Views: 100

Locations of visitors to this page